summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:15:15 +0800
committerSukanka2022-06-07 01:15:15 +0800
commitca1823e12208fbcc709337141d0df8e9f7c93620 (patch)
tree907f3fe1b55c4c968c5b1dbada36f40c83607d5f
downloadaur-ca1823e12208fbcc709337141d0df8e9f7c93620.tar.gz
add r-systempipeshiny
-rw-r--r--.SRCINFO68
-rw-r--r--PKGBUILD84
2 files changed, 152 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d590f555f2a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,68 @@
+pkgbase = r-systempipeshiny
+ pkgdesc = systemPipeShiny: An Interactive Framework for Workflow Management and Visualization
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://bioconductor.org/packages/systemPipeShiny
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-assertthat
+ depends = r-bsplus
+ depends = r-crayon
+ depends = r-dplyr
+ depends = r-drawer
+ depends = r-dt
+ depends = r-ggplot2
+ depends = r-glue
+ depends = r-htmltools
+ depends = r-magrittr
+ depends = r-openssl
+ depends = r-plotly
+ depends = r-r6
+ depends = r-rlang
+ depends = r-rsqlite
+ depends = r-rstudioapi
+ depends = r-shiny
+ depends = r-shinyace
+ depends = r-shinydashboard
+ depends = r-shinydashboardplus
+ depends = r-shinyfiles
+ depends = r-shinyjqui
+ depends = r-shinyjs
+ depends = r-shinytoastr
+ depends = r-shinywidgets
+ depends = r-spscomps
+ depends = r-spsutil
+ depends = r-stringr
+ depends = r-styler
+ depends = r-tibble
+ depends = r-vroom
+ depends = r-yaml
+ optdepends = r-ape
+ optdepends = r-biocstyle
+ optdepends = r-callr
+ optdepends = r-cicerone
+ optdepends = r-deseq2
+ optdepends = r-esquisse
+ optdepends = r-fs
+ optdepends = r-glmpca
+ optdepends = r-grid
+ optdepends = r-knitr
+ optdepends = r-pheatmap
+ optdepends = r-pushbar
+ optdepends = r-r.utils
+ optdepends = r-readr
+ optdepends = r-rhandsontable
+ optdepends = r-rmarkdown
+ optdepends = r-rtsne
+ optdepends = r-summarizedexperiment
+ optdepends = r-systempiper
+ optdepends = r-systempiperdata
+ optdepends = r-testthat
+ optdepends = r-tidyr
+ optdepends = r-upsetr
+ optdepends = r-zip
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/systemPipeShiny_1.6.1.tar.gz
+ sha256sums = 56b2c4568ffb3d2c37e1c9c6d3a515e1b3287931b744c08070f7ce7afc4e1dac
+
+pkgname = r-systempipeshiny
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb8d8a915773
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,84 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=systemPipeShiny
+_pkgver=1.6.1
+pkgname=r-${_pkgname,,}
+pkgver=1.6.1
+pkgrel=1
+pkgdesc='systemPipeShiny: An Interactive Framework for Workflow Management and Visualization'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-assertthat
+ r-bsplus
+ r-crayon
+ r-dplyr
+ r-drawer
+ r-dt
+ r-ggplot2
+ r-glue
+ r-htmltools
+ r-magrittr
+ r-openssl
+ r-plotly
+ r-r6
+ r-rlang
+ r-rsqlite
+ r-rstudioapi
+ r-shiny
+ r-shinyace
+ r-shinydashboard
+ r-shinydashboardplus
+ r-shinyfiles
+ r-shinyjqui
+ r-shinyjs
+ r-shinytoastr
+ r-shinywidgets
+ r-spscomps
+ r-spsutil
+ r-stringr
+ r-styler
+ r-tibble
+ r-vroom
+ r-yaml
+)
+optdepends=(
+ r-ape
+ r-biocstyle
+ r-callr
+ r-cicerone
+ r-deseq2
+ r-esquisse
+ r-fs
+ r-glmpca
+ r-grid
+ r-knitr
+ r-pheatmap
+ r-pushbar
+ r-r.utils
+ r-readr
+ r-rhandsontable
+ r-rmarkdown
+ r-rtsne
+ r-summarizedexperiment
+ r-systempiper
+ r-systempiperdata
+ r-testthat
+ r-tidyr
+ r-upsetr
+ r-zip
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('56b2c4568ffb3d2c37e1c9c6d3a515e1b3287931b744c08070f7ce7afc4e1dac')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: