summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirk Gleason2015-08-22 22:24:07 -0400
committerKirk Gleason2015-08-22 22:24:07 -0400
commitca27a2d50fbb9cc7d64cbed70ff77dafb258d724 (patch)
tree71b151850dd4357cbe9da4e3e30bdbf2a580599f
downloadaur-ca27a2d50fbb9cc7d64cbed70ff77dafb258d724.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19e952a0c5f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lightum-git
+ pkgdesc = Lightum is a daemon to control the keyboard brightness and screen backlight on MacBook based laptops.
+ pkgver = 2.3.1
+ pkgrel = 1
+ url = https://github.com/poliva/lightum
+ arch = i386
+ arch = x86_64
+ license = GPL2
+ source = lightum-git::git://github.com/poliva/lightum.git
+ md5sums = SKIP
+
+pkgname = lightum-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..079c06c63a72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+#Maintainer: "Kirk Gleason <kirk at kirkg dot us>"
+pkgname=lightum-git
+pkgver=2.3.1
+pkgrel=1
+pkgdesc="Lightum is a daemon to control the keyboard brightness and screen backlight on MacBook based laptops."
+arch=(i386 x86_64)
+url="https://github.com/poliva/lightum"
+license=('GPL2')
+md5sums=(SKIP)
+#source=('lightum-git::git+https://github.com/poliva/lightum.git')
+source=('lightum-git::git://github.com/poliva/lightum.git')
+pkgver() {
+ cd "$pkgname"
+ git describe --always | sed 's|v||;s|-.*||'
+}
+
+prepare() {
+ cd "$pkgname"
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+check() {
+ cd "$pkgname"
+ true
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}