summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedroHLC2019-12-09 16:30:24 -0300
committerPedroHLC2019-12-09 16:32:01 -0300
commitca4eeb4a5c98dab5bffb8e0803d1dcf718b1a792 (patch)
treec5d85594835f39863fa0a902c773ea625381ea04
parent886e7bb3a2ac3395ccf4305ad07f913b38a157f3 (diff)
downloadaur-ca4eeb4a5c98dab5bffb8e0803d1dcf718b1a792.tar.gz
Update to 1.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31132894676d..abe4d21da775 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wlcs
pkgdesc = Canonical's protocol-conformance-verifying test suite for Wayland compositor implementations.
- pkgver = 1.0.0
- pkgrel = 0
+ pkgver = 1.1.0
+ pkgrel = 1
url = https://github.com/MirServer/wlcs
arch = x86_64
arch = i686
@@ -14,8 +14,8 @@ pkgbase = wlcs
depends = gtest
depends = boost-libs
depends = wayland
- source = https://github.com/MirServer/wlcs/releases/download/v1.0.0/wlcs-1.0.0.tar.xz
- sha256sums = 8d88e029c5bac25d2995e916d5cc145006347f3541e5c1e1dc7c8f17ade8e1d4
+ source = https://github.com/MirServer/wlcs/releases/download/v1.1.0/wlcs-1.1.0.tar.xz
+ sha256sums = 7238dd4a0fece16b7eb21db90722795fb68f20e0fcfc82ab01bce5b63ca415d1
pkgname = wlcs
diff --git a/PKGBUILD b/PKGBUILD
index 8c6331f892c8..e14e3204dcba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
pkgname=wlcs
-pkgver=1.0.0
-pkgrel=0
+pkgver=1.1.0
+_tardirname=1.0.0
+pkgrel=1
pkgdesc="Canonical's protocol-conformance-verifying test suite for Wayland compositor implementations."
url='https://github.com/MirServer/wlcs'
arch=(x86_64 i686)
@@ -9,12 +10,12 @@ depends=(gtest boost-libs wayland)
makedepends=(git cmake boost gmock wayland-protocols)
optdepends=()
source=("https://github.com/MirServer/wlcs/releases/download/v${pkgver}/wlcs-${pkgver}.tar.xz")
-sha256sums=('8d88e029c5bac25d2995e916d5cc145006347f3541e5c1e1dc7c8f17ade8e1d4')
+sha256sums=('7238dd4a0fece16b7eb21db90722795fb68f20e0fcfc82ab01bce5b63ca415d1')
BUILD_DIR=build
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-${_tardirname}"
mkdir -p "${BUILD_DIR}"
cd "${BUILD_DIR}"
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_INSTALL_LIBDIR="lib/" ..
@@ -22,8 +23,8 @@ build() {
}
package() {
- cd "${pkgname}-${pkgver}/${BUILD_DIR}"
+ cd "${pkgname}-${_tardirname}/${BUILD_DIR}"
make DESTDIR="${pkgdir}/" install
}
-# vim:set ts=2 sw=2 et: \ No newline at end of file
+# vim:set ts=2 sw=2 et: