summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002020-05-16 19:32:22 +0200
committer0x9fff002020-05-16 19:32:22 +0200
commitca9d1d8d4d17255c6c7d00ecfdab95c41b1c6ff1 (patch)
tree00fb26accad7f861dce47277bd6c00b436c21aba
downloadaur-ca9d1d8d4d17255c6c7d00ecfdab95c41b1c6ff1.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore28
-rw-r--r--.gitignore_append2
-rw-r--r--PKGBUILD37
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a11182ddeda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pymctranslate-git
+ pkgdesc = A library of block mappings that can be used to convert from any Minecraft format into any other Minecraft format
+ pkgver = r409.edd274e3
+ pkgrel = 1
+ url = https://github.com/gentlegiantJGC/PyMCTranslate
+ arch = any
+ license = custom
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ provides = python-pymctranslate
+ conflicts = python-pymctranslate
+ options = !strip
+ source = git+https://github.com/gentlegiantJGC/PyMCTranslate.git
+ sha256sums = SKIP
+
+pkgname = python-pymctranslate-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7da4dce45dfb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,28 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+# archlinuxpackages linux
+PyMCTranslate
diff --git a/.gitignore_append b/.gitignore_append
new file mode 100644
index 000000000000..e4d26308efe8
--- /dev/null
+++ b/.gitignore_append
@@ -0,0 +1,2 @@
+# archlinuxpackages linux
+PyMCTranslate
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1df42d9ba12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
+
+_name=PyMCTranslate
+_pkgname=python-${_name,,}
+pkgname=$_pkgname-git
+pkgver=r409.edd274e3
+pkgrel=1
+pkgdesc='A library of block mappings that can be used to convert from any Minecraft format into any other Minecraft format'
+arch=('any')
+url="https://github.com/gentlegiantJGC/$_name"
+license=('custom')
+depends=('python' 'python-numpy')
+makedepends=('git' 'python-setuptools')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+options=(!strip) # strip is extremely slow and there are no ELF files anyway
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_name"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_name"
+
+ python setup.py build
+}
+
+package() {
+ cd "$_name"
+
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}