summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKartik Mohta2022-09-12 14:18:03 +0530
committerKartik Mohta2022-09-12 14:18:03 +0530
commitcaaa9a3794c0f451d3a5fd31bb40755478e4a021 (patch)
tree0bbad2f477edc382d0de1cfb7bbcc4f4fdb539f8
parentaf6d7a109bce8bbf52a443a1f2d9ced759f8d335 (diff)
downloadaur-caaa9a3794c0f451d3a5fd31bb40755478e4a021.tar.gz
Change to use git src since the setup.py assumes it is run from a git clone
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27cacff15d7b..3f7662327bd1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-catkin_lint
pkgdesc = Check catkin packages for common errors
pkgver = 1.6.18
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fkie/catkin_lint
arch = any
license = BSD
@@ -12,7 +12,7 @@ pkgbase = python-catkin_lint
provides = python-catkin-lint
conflicts = python2-catkin_lint
conflicts = python-catkin-lint
- source = https://github.com/fkie/catkin_lint/archive/1.6.18.tar.gz
- sha256sums = 2cd38c4a94df1fb201617a7a79dbf46572c6d98024be7b8e7dccfa4c79ff2c29
+ source = git+https://github.com/fkie/catkin_lint.git#tag=1.6.18
+ sha256sums = SKIP
pkgname = python-catkin_lint
diff --git a/PKGBUILD b/PKGBUILD
index 8bc4f246d517..14dd2e3c8c59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=('python-catkin_lint')
pkgver='1.6.18'
-pkgrel=1
+pkgrel=2
pkgdesc='Check catkin packages for common errors'
arch=('any')
url='https://github.com/fkie/catkin_lint'
@@ -11,17 +11,17 @@ depends=('python' 'python-catkin_pkg' 'python-lxml')
makedepends=('python-setuptools')
provides=('python-catkin-lint')
conflicts=('python2-catkin_lint' 'python-catkin-lint')
-source=("https://github.com/fkie/catkin_lint/archive/${pkgver}.tar.gz")
-sha256sums=('2cd38c4a94df1fb201617a7a79dbf46572c6d98024be7b8e7dccfa4c79ff2c29')
+source=("git+https://github.com/fkie/catkin_lint.git#tag=${pkgver}")
+sha256sums=('SKIP')
_module='catkin_lint'
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_module}"
python setup.py build
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_module}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}