summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgt2015-06-17 10:26:32 +0530
committergt2015-06-17 10:26:32 +0530
commitcab5bc8b3e9a8eaabd2b62a4f931eb7b911612fe (patch)
treeb32b0fe1bf2ddc3f05d8f13b84dc3cdc2429c04c
downloadaur-cab5bc8b3e9a8eaabd2b62a4f931eb7b911612fe.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b500209dcbd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dex-editor-git
+ pkgdesc = dex - dextrous text editor. A small and lightweight command line based text editor.
+ pkgver = 1882.dbfe91c
+ pkgrel = 1
+ url = http://github.com/tihirvon/dex
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = glibc
+ depends = ncurses
+ source = dex-editor-git::git+https://github.com/tihirvon/dex.git
+ md5sums = SKIP
+
+pkgname = dex-editor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2646743e3e79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: notfoss <AT> gmx.com
+
+pkgname="dex-editor-git"
+pkgver="1882.dbfe91c"
+pkgrel="1"
+pkgdesc="dex - dextrous text editor. A small and lightweight command line based text editor."
+arch=("i686" "x86_64")
+url="http://github.com/tihirvon/dex"
+license=("GPL2")
+depends=("glibc" "ncurses")
+makedepends=("git")
+source=("$pkgname"::"git+https://github.com/tihirvon/dex.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ # use the total number of commits + SHA-1 (first 7 characters) of the last commit
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$pkgname"
+ make prefix=/usr DESTDIR="$pkgdir"
+}
+
+package() {
+ cd "$pkgname"
+ make prefix=/usr DESTDIR="$pkgdir" install
+}