summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConorIA2016-06-09 15:48:28 -0400
committerConorIA2016-06-09 15:48:28 -0400
commitcac2c403e01569cb2ac93442d12b35e15eef7519 (patch)
tree742e752a5537e7f9ff14052959241b98faad5925
downloadaur-cac2c403e01569cb2ac93442d12b35e15eef7519.tar.gz
initial commit
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD40
-rw-r--r--pqr.desktop10
-rw-r--r--pqr.install9
-rw-r--r--pqr.pngbin0 -> 362 bytes
5 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfdab30f28ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = pqr
+ pkgdesc = a pretty quick version of R
+ pkgver = 20150914
+ pkgrel = 1
+ url = http://www.pqr-project.org/
+ install = pqr.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-fortran
+ depends = blas
+ depends = lapack
+ depends = bzip2
+ depends = libpng
+ depends = libjpeg
+ depends = libtiff
+ depends = ncurses
+ depends = pcre
+ depends = readline
+ depends = zlib
+ depends = perl
+ depends = gcc-libs
+ depends = libxt
+ depends = libxmu
+ depends = pango
+ depends = xz
+ depends = desktop-file-utils
+ depends = zip
+ depends = unzip
+ optdepends = tk: tcl/tk interface
+ optdepends = texlive-bin: latex sty files
+ options = !makeflags
+ options = !emptydirs
+ source = http://www.pqr-project.org/pqR-2015-09-14.tar.gz
+ source = pqr.desktop
+ source = pqr.png
+ md5sums = 5f1f65f3c71f2f27c33c2901417bcbfe
+ md5sums = 543264e50f64a1c5bdf1465e3961b188
+ md5sums = 8a535cb19598efcf31a5e757b6d74217
+
+pkgname = pqr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..221045ec8f78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Conor Anderson <conor[dot]anderson[at]utoronto.ca>
+pkgname=pqr
+_pkgver="2015-09-14"
+pkgver=${_pkgver//-/}
+pkgrel=1
+pkgdesc="a pretty quick version of R"
+arch=('i686' 'x86_64')
+url="http://www.pqr-project.org/"
+license=('GPL')
+depends=('blas' 'lapack' 'bzip2' 'libpng' 'libjpeg' 'libtiff'
+ 'ncurses' 'pcre' 'readline' 'zlib' 'perl' 'gcc-libs'
+ 'libxt' 'libxmu' 'pango' 'xz' 'desktop-file-utils' 'zip' 'unzip')
+makedepends=('gcc-fortran')
+optdepends=('tk: tcl/tk interface' 'texlive-bin: latex sty files')
+options=('!makeflags' '!emptydirs')
+install=$pkgname.install
+source=("http://www.pqr-project.org/pqR-${_pkgver}.tar.gz"
+ 'pqr.desktop'
+ 'pqr.png')
+md5sums=('5f1f65f3c71f2f27c33c2901417bcbfe'
+ '543264e50f64a1c5bdf1465e3961b188'
+ '8a535cb19598efcf31a5e757b6d74217')
+
+build() {
+ cd "pqR-${_pkgver}"
+ ./configure --prefix=/opt/pqr --enable-R-shlib
+ make
+}
+
+package() {
+ cd "pqR-${_pkgver}"
+
+ make DESTDIR="${pkgdir}/" install
+
+ # install some freedesktop.org compatibility (borrowed form r-devel)
+ install -Dm644 "${srcdir}/pqr.desktop" \
+ "${pkgdir}/usr/share/applications/pqr.desktop"
+ install -Dm644 "${srcdir}/pqr.png" \
+ "${pkgdir}/opt/pqr/pqr.png"
+}
diff --git a/pqr.desktop b/pqr.desktop
new file mode 100644
index 000000000000..f0a5d1a67fab
--- /dev/null
+++ b/pqr.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=pqR
+GenericName=environment for statistical computing
+Comment=a pretty quick version of R
+Exec=/opt/pqr/bin/R
+Icon=/opt/pqr/pqr.png
+StartupNotify=true
+Terminal=true
+Type=Application
+Categories=Science;
diff --git a/pqr.install b/pqr.install
new file mode 100644
index 000000000000..9686cff249ec
--- /dev/null
+++ b/pqr.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "pqR has been installed to /opt/pqr"
+ echo "to use with RStudio set your environment variables like: export RSTUDIO_WHICH_R='/opt/pqr/bin/R'"
+}
+
+post_upgrade() {
+ post_install
+}
+
diff --git a/pqr.png b/pqr.png
new file mode 100644
index 000000000000..27d45ab25ec1
--- /dev/null
+++ b/pqr.png
Binary files differ