summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-10-15 09:58:25 -0600
committerMark Wagie2023-10-15 09:58:25 -0600
commitcae252c4d66e9a0350e4d7357d8d4edd2620b43b (patch)
treea5e65dbef6dbcfd1af4589d40fe6c9fcbe475034
parent55400f8382ccafb18115707d6fc710350a8d583a (diff)
downloadaur-cae252c4d66e9a0350e4d7357d8d4edd2620b43b.tar.gz
apply PR 137 for GNOME 45
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 057a104339dc..3a2143f9fbd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-rounded-window-corners-git
pkgdesc = A GNOME Shell extension that adds rounded corners for all windows
- pkgver = 11.r12.gce88738
- pkgrel = 3
+ pkgver = 11.r19.g8ec8275
+ pkgrel = 1
url = https://github.com/yilozt/rounded-window-corners
arch = any
license = GPL3
@@ -9,10 +9,12 @@ pkgbase = gnome-shell-extension-rounded-window-corners-git
makedepends = gobject-introspection
makedepends = yarn
makedepends = zip
- depends = gnome-shell<=1:44.6
+ depends = gnome-shell
provides = gnome-shell-extension-rounded-window-corners
conflicts = gnome-shell-extension-rounded-window-corners
source = git+https://github.com/yilozt/rounded-window-corners.git
+ source = https://github.com/yilozt/rounded-window-corners/pull/137.patch
sha256sums = SKIP
+ sha256sums = d2e88e6136651610b961e9b0f98e49ffb6e2bf78aad5b239988752b4094cf98f
pkgname = gnome-shell-extension-rounded-window-corners-git
diff --git a/PKGBUILD b/PKGBUILD
index 7f8561311229..291cca0fce2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,35 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
# Co-Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=gnome-shell-extension-rounded-window-corners-git
-pkgver=11.r12.gce88738
-pkgrel=3
+pkgver=11.r19.g8ec8275
+pkgrel=1
pkgdesc="A GNOME Shell extension that adds rounded corners for all windows"
arch=('any')
url="https://github.com/yilozt/rounded-window-corners"
license=('GPL3')
-depends=('gnome-shell<=1:44.6')
+depends=('gnome-shell')
makedepends=('git' 'gobject-introspection' 'yarn' 'zip')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/yilozt/rounded-window-corners.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/yilozt/rounded-window-corners.git'
+ 'https://github.com/yilozt/rounded-window-corners/pull/137.patch')
+sha256sums=('SKIP'
+ 'd2e88e6136651610b961e9b0f98e49ffb6e2bf78aad5b239988752b4094cf98f')
pkgver() {
- cd "$srcdir/rounded-window-corners"
+ cd rounded-window-corners
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd rounded-window-corners
+
+ # WIP: Gnome 45 port
+ patch -Np1 -i ../137.patch
+}
+
build() {
- cd "$srcdir/rounded-window-corners"
+ cd rounded-window-corners
export YARN_CACHE_FOLDER="$srcdir/yarn-cache"
yarn install
yarn build
@@ -28,7 +37,7 @@ build() {
}
package() {
- cd "$srcdir/rounded-window-corners"
+ cd rounded-window-corners
local uuid=$(grep -Po '(?<="uuid": ")[^"]*' _build/metadata.json)
install -d "$pkgdir/usr/share/gnome-shell/extensions/${uuid}"