summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernard Baeyens2019-09-02 15:29:52 +0200
committerBernard Baeyens2019-09-02 15:29:52 +0200
commitcb0836507606ad791c007460f70d0db075f5f248 (patch)
treee2ae5b9ba05a044627c4c177fc7b40a4aa72cd97
parentda1ccade4d6bcd904810678ddb5ff0a0d273b9af (diff)
downloadaur-cb0836507606ad791c007460f70d0db075f5f248.tar.gz
patch for scons python3 syntax
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
-rw-r--r--ipager-1.1.0-20190902.patch50
3 files changed, 64 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba1e482f95f3..16aa88b87816 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,9 @@
-# Generated by mksrcinfo v8
-# Mon Dec 21 15:40:35 UTC 2015
pkgbase = ipager
pkgdesc = a lightweight beautiful pager from Fluxbox
pkgver = 1.1.0
- pkgrel = 11
+ pkgrel = 12
url = http://fluxbox.org/screenshots/
install = ipager.install
- arch = i686
arch = x86_64
license = MIT
makedepends = patch
@@ -15,8 +12,10 @@ pkgbase = ipager
depends = libxmu
source = http://slackware.uk/slacky/slackware-13.0/desktop/ipager/1.1.0/src/ipager-1.1.0.tar.gz
source = ipager-1.1.0-20120429.patch
+ source = ipager-1.1.0-20190902.patch
md5sums = d74409836f5c31eb55a55f00783b1f6f
md5sums = 073682d8f76e1e91b9d3f2415f4a6c52
+ md5sums = 3ca6f620f8897122d07e966c10571673
pkgname = ipager
diff --git a/PKGBUILD b/PKGBUILD
index 0a5c7e7c39f7..394aaf6704c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,28 @@
pkgname=ipager
pkgver=1.1.0
-pkgrel=11
+pkgrel=12
pkgdesc="a lightweight beautiful pager from Fluxbox"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('MIT')
#url="http://www.useperl.ru/ipager/index.en.html"
url="http://fluxbox.org/screenshots/"
depends=('imlib2' 'libxmu')
makedepends=('patch' 'scons')
#source=(http://www.useperl.ru/ipager/src/ipager-$pkgver.tar.gz ipager-1.1.0-20120429.patch)
-source=(http://slackware.uk/slacky/slackware-13.0/desktop/ipager/1.1.0/src/ipager-1.1.0.tar.gz ipager-1.1.0-20120429.patch)
+source=(http://slackware.uk/slacky/slackware-13.0/desktop/ipager/1.1.0/src/ipager-1.1.0.tar.gz
+ ipager-1.1.0-20120429.patch ipager-1.1.0-20190902.patch)
install=$pkgname.install
-md5sums=('d74409836f5c31eb55a55f00783b1f6f' '073682d8f76e1e91b9d3f2415f4a6c52')
+md5sums=('d74409836f5c31eb55a55f00783b1f6f' '073682d8f76e1e91b9d3f2415f4a6c52' '3ca6f620f8897122d07e966c10571673')
-build() {
+prepare() {
cd $srcdir/$pkgname-$pkgver
patch -p0 < $srcdir/ipager-1.1.0-20120429.patch
+patch -p0 < $srcdir/ipager-1.1.0-20190902.patch
+}
+
+build() {
+cd $srcdir/$pkgname-$pkgver
scons
}
diff --git a/ipager-1.1.0-20190902.patch b/ipager-1.1.0-20190902.patch
new file mode 100644
index 000000000000..0bfd4d2a43e0
--- /dev/null
+++ b/ipager-1.1.0-20190902.patch
@@ -0,0 +1,50 @@
+-- SConstruct.orig 2019-09-01 11:41:55.808084988 -0400
++++ SConstruct 2019-09-01 11:24:34.220907783 -0400
+@@ -74,12 +74,12 @@
+
+ # sys/stat.h
+ if not conf.CheckCHeader('sys/stat.h'):
+- print "missing 'sys/stat.h', install it."
++ print ("missing 'sys/stat.h', install it.")
+ exit(1)
+
+ # sys/types.h
+ if not conf.CheckCHeader('sys/types.h'):
+- print "missing 'sys/types.h', install it."
++ print ("missing 'sys/types.h', install it.")
+ exit(1)
+
+
+@@ -91,7 +91,7 @@
+ ipager_env.AppendUnique(
+ LIBS = ['X11','Xmu','Xext'])
+ else:
+- print "missing x11-dev-stuff, install it."
++ print ("missing x11-dev-stuff, install it.")
+ exit(1)
+
+
+@@ -103,18 +103,18 @@
+
+
+ # imlib2
+-print "Checking for Imlib2... ",
++print ("Checking for Imlib2... ",)
+ if not conf.env.WhereIs('imlib2-config'):
+- print "cant find 'imlib2-config."
++ print ("cant find 'imlib2-config.")
+ exit(1)
+ else:
+ imlib2_env = Environment()
+ imlib2_env.ParseConfig('imlib2-config --cflags --libs')
+ if not imlib2_env.Dictionary()['LIBS']:
+- print "missing imlib2, install it."
++ print ("missing imlib2, install it.")
+ exit(1)
+ else:
+- print "yes"
++ print ("yes")
+ ipager_env.AppendUnique(
+ CPPPATH = imlib2_env.Dictionary().get('CPPPATH'),
+ CCFLAGS = imlib2_env.Dictionary().get('CCFLAGS'),
+