summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsehraf2021-03-24 17:48:09 +0100
committersehraf2021-03-24 17:48:09 +0100
commitcb31b52614882d75382aba4e3a566e1cde9045be (patch)
tree0af18ff4d08dd42b21e98563717fe18668b57194
parenta3216a098ce1a40b0dbb1bde9d2fe9c18830e89f (diff)
downloadaur-cb31b52614882d75382aba4e3a566e1cde9045be.tar.gz
fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 7 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27fee59ab76d..079daf0c0915 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = retroshare-git
pkgdesc = Serverless encrypted instant messenger with filesharing, chatgroups, e-mail.
- pkgver = v0.6.6.r0.g751fffc30
+ pkgver = v0.6.6.r8.g67c607cb3
pkgrel = 1
url = http://retroshare.cc/
arch = i686
@@ -12,6 +12,8 @@ pkgbase = retroshare-git
license = LGPL
makedepends = git
makedepends = qt5-tools
+ makedepends = rapidjson
+ makedepends = cmake
depends = qt5-multimedia
depends = qt5-x11extras
depends = miniupnpc
diff --git a/PKGBUILD b/PKGBUILD
index 50984e69ed29..4cba7f53455a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,9 +20,6 @@ _nativ_dialogs='true'
# Set this to 'true' to use clang for compiling (experimental)
#_clang='true'
-# Unofficial plugins
-#_plugin_lua4rs='true'
-
# INCOMPATIBLE OPTION - Do not swtich between different version with this enabled and disbaled! RetroShare required _manual_ migration!
# Set this to 'true' to not used an encrypted database. This will likely enhance your performance.
#_no_sqlcipher='true'
@@ -31,14 +28,14 @@ _nativ_dialogs='true'
_pkgname=retroshare
pkgname=${_pkgname}-git
-pkgver=v0.6.6.r0.g751fffc30
+pkgver=v0.6.6.r8.g67c607cb3
pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url='http://retroshare.cc/'
license=('GPL' 'LGPL')
depends=('qt5-multimedia' 'qt5-x11extras' 'miniupnpc' 'libxss' 'libmicrohttpd' 'xapian-core')
-makedepends=('git' 'qt5-tools')
+makedepends=('git' 'qt5-tools' 'rapidjson' 'cmake')
optdepends=('tor: tor hidden node support'
'i2p: i2p hidden node support'
'i2pd: i2p hidden node support' )
@@ -56,7 +53,7 @@ _optSql=''
# Add missing dependencies if needed
[[ "$_plugin_voip" == 'true' ]] && depends=(${depends[@]} 'ffmpeg' 'opencv')
[[ "$_plugin_feedreader" == 'true' ]] && depends=(${depends[@]} 'curl' 'libxslt')
-[[ "$_jsonapi" == 'true' ]] && makedepends=(${makedepends[@]} 'cmake' 'doxygen' 'rapidjson')
+[[ "$_jsonapi" == 'true' ]] && makedepends=(${makedepends[@]} 'cmake' 'doxygen')
[[ "$_clang" == 'true' ]] && makedepends=(${makedepends[@]} 'clang')
[[ "$_autologin" == 'true' ]] && depends=(${depends[@]} 'libsecret')
@@ -71,7 +68,7 @@ _optNativDialogs=''
[[ "$_clang" == 'true' ]] && _optClang='-spec linux-clang'
[[ "$_autologin" == 'true' ]] && _optAutol='CONFIG+=rs_autologin'
[[ "$_nativ_dialogs" == 'true' ]] && _optNativDialogs='CONFIG*=rs_use_native_dialogs'
-([[ "$_plugin_voip" == 'true' ]] || [[ "$_plugin_feedreader" == 'true' ]] || [[ "$_plugin_lua4rs" == 'true' ]]) && _optPlugin='CONFIG+=retroshare_plugins'
+([[ "$_plugin_voip" == 'true' ]] || [[ "$_plugin_feedreader" == 'true' ]]) && _optPlugin='CONFIG+=retroshare_plugins'
[[ "$_wiki" == 'true' ]] && _optWiki='CONFIG+=wikipoos'
# Handle unofficial plugins
@@ -89,13 +86,6 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- # Handle unofficial plugins
- if [[ "$_plugin_lua4rs" == 'true' ]] ; then
- [[ -d 'plugins/Lua4RS' ]] && rm -r plugins//Lua4RS
- cp -r -l "${srcdir}/Lua4RS" plugins/
- sed -i -e 's/SUBDIRS += \\/SUBDIRS += \\\n\t\tLua4RS \\/g' plugins/plugins.pro
- fi
-
# remove unwanted plugins
[[ "$_plugin_voip" != 'true' ]] && sed -i '/VOIP \\/d' plugins/plugins.pro
[[ "$_plugin_feedreader" != 'true' ]] && sed -i '/FeedReader/d' plugins/plugins.pro