summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreveryx2023-03-20 20:15:54 +0800
committereveryx2023-03-20 20:15:54 +0800
commitcb3e919a8a8173f654ef8d687ff4f3814ecc9c69 (patch)
treecd7f89d4890b011845068cbd47829337ffe9389f
parent5ca7b415417737aa556fa440b5247faa265c46e7 (diff)
downloadaur-cb3e919a8a8173f654ef8d687ff4f3814ecc9c69.tar.gz
fix: update to 0.3.8.r20.g0b254f1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 457edc7e2339..c6bf1958f17f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = yacd-git
pkgdesc = Yet Another Clash Dashboard
- pkgver = 20230212.1
+ pkgver = 0.3.8.r20.g0b254f1
pkgrel = 1
url = https://github.com/haishanh/yacd
arch = any
license = MIT
+ makedepends = git
+ makedepends = pnpm
optdepends = clash: A rule-based tunnel in Go
optdepends = sing-box: The universal proxy platform
provides = yacd
conflicts = yacd
- source = yacd::git+https://github.com/haishanh/yacd.git#branch=gh-pages
+ source = yacd::git+https://github.com/haishanh/yacd.git#branch=master
sha256sums = SKIP
pkgname = yacd-git
diff --git a/PKGBUILD b/PKGBUILD
index 0d764c9cd765..973809434e68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=yacd-git
_pkgname=yacd
-pkgver=20230212.1
+pkgver=0.3.8.r20.g0b254f1
pkgrel=1
pkgdesc='Yet Another Clash Dashboard'
@@ -11,21 +11,27 @@ _repo="haishanh/${_pkgname}"
url="https://github.com/${_repo}"
license=('MIT')
+makedepends=('git' 'pnpm')
optdepends=('clash: A rule-based tunnel in Go'
'sing-box: The universal proxy platform')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("${_pkgname}::git+${url}.git#branch=gh-pages")
+source=("${_pkgname}::git+${url}.git#branch=master")
sha256sums=(SKIP)
pkgver() {
cd "$_pkgname"
- git log --date=short --pretty=format:%ad | sort | uniq -c | awk '{print $2,$1}' | head -n1 | sed 's/-//g;s/ /./g'
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
+build () {
cd "$_pkgname"
+ pnpm i && pnpm build
+}
+
+package() {
+ cd "$_pkgname/public"
find . -type f -exec install -Dm 644 {} "${pkgdir}"/usr/share/"${_pkgname}"/{} \;
}