summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpancho horrillo2020-05-16 07:53:24 +0200
committerpancho horrillo2020-05-16 07:53:24 +0200
commitcb4ed823ece6b3316a7b4103135dec8d1711473c (patch)
treee27ea06007c31c63b96916b66feb40c53726e827
parenteed07623825bf13f642db42d8bef6f4e65325636 (diff)
downloadaur-cb4ed823ece6b3316a7b4103135dec8d1711473c.tar.gz
Workaround issue with GCC 10
GCC 10 defaults to `-fno-common`¹, producing a linker error with current codebase. As a workaround, I've forced `-fcommon` when configuring. See also the topic² on bbs.archlinux.org for more details. Also, it seems that the `validpgpkeys` entry was not added in `.SRCINFO`, possibly because I used `mksrcinfo` to create it. Now that I'm using `makepkg --printsrcinfo`, it gets added nicely. ¹: https://gcc.gnu.org/gcc-10/porting_to.html ²: https://bbs.archlinux.org/viewtopic.php?id=255727
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 010876d532ac..fa3e2b412cf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Tue Feb 5 18:58:23 UTC 2019
pkgbase = pam_ssh
pkgdesc = PAM module providing single sign-on behavior for SSH.
pkgver = 2.3
- pkgrel = 1
+ pkgrel = 2
url = http://pam-ssh.sourceforge.net/
install = pam_ssh.install
arch = i686
@@ -15,6 +13,7 @@ pkgbase = pam_ssh
options = !libtool
source = https://sourceforge.net/projects/pam-ssh/files/pam_ssh/2.3/pam_ssh-2.3.tar.xz
source = https://sourceforge.net/projects/pam-ssh/files/pam_ssh/2.3/pam_ssh-2.3.tar.xz.asc
+ validpgpkeys = 501B088D8485568B87BB62BE180F6A5B3EDE742E
sha512sums = e3ddcf851ffd8f6fb831e2dee7269c1b89283ae2f8f6aa3487bf7b1bc71d26ac9bcbd2a01c5a67a983b980bbb5151e991402940f4752741286d057843c817895
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bb73b6726784..03aaf0ce41ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=pam_ssh
pkgver=2.3
-pkgrel=1
+pkgrel=2
pkgdesc='PAM module providing single sign-on behavior for SSH.'
arch=('i686' 'x86_64')
url='http://pam-ssh.sourceforge.net/'
@@ -23,7 +23,7 @@ validpgpkeys=(
build () {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --with-pam-dir=/usr/lib/security
+ CFLAGS="$CFLAGS -fcommon" ./configure --prefix=/usr --with-pam-dir=/usr/lib/security
make
}