summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2018-01-23 13:28:30 +0100
committerAlbert Graef2018-01-23 13:28:30 +0100
commitcba87a0396b51cb76ea842218c1697b1fbfbfb57 (patch)
treec6333344dbe56ea51bd03d9de1e1773bd8732004
parent66e4602a3cefc1003db3aaca20373145fdba6fb4 (diff)
downloadaur-cba87a0396b51cb76ea842218c1697b1fbfbfb57.tar.gz
PKGBUILD and Python2 fixes, faust-mode.el is now included in the Faust source.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--python2-fix.patch10
3 files changed, 21 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3f84dc76ca1..0adf27b27152 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jan 19 20:43:55 UTC 2018
+# Tue Jan 23 12:23:33 UTC 2018
pkgbase = faust-git
pkgdesc = A functional programming language for realtime audio signal processing.
- pkgver = 2.5.17.r9470.455f4e95e
+ pkgver = 2.5.17.r9479.1a4ac773e
pkgrel = 1
epoch = 2
url = http://faust.grame.fr/
@@ -25,11 +25,9 @@ pkgbase = faust-git
options = strip
options = staticlibs
source = faust-git::git+https://github.com/grame-cncm/faust.git#branch=master-dev
- source = git+https://github.com/agraef/emacs-faust-mode.git
source = python2-fix.patch
md5sums = SKIP
- md5sums = SKIP
- md5sums = 8680b87fc4e34445e02f34781ee45f19
+ md5sums = 5bd95373f2d6f4e86a2befab669339f8
pkgname = faust-git
diff --git a/PKGBUILD b/PKGBUILD
index 814b886024bb..e9c85dfe8d47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: bjoern lindig (bjoern _dot_ lindig _at_ google.com)
pkgname=faust-git
-pkgver=2.5.17.r9470.455f4e95e
+pkgver=2.5.17.r9479.1a4ac773e
pkgrel=1
epoch=2
pkgdesc="A functional programming language for realtime audio signal processing."
@@ -32,10 +32,9 @@ options=('strip' 'staticlibs')
# latest changes. End users might want to use the master branch instead, which
# is supposedly more stable and tested, but nevertheless (mostly) up-to-date.
source=("$pkgname::git+https://github.com/grame-cncm/faust.git#branch=master-dev"
- "git+https://github.com/agraef/emacs-faust-mode.git"
"python2-fix.patch")
-md5sums=('SKIP' 'SKIP'
- '8680b87fc4e34445e02f34781ee45f19')
+md5sums=('SKIP'
+ '5bd95373f2d6f4e86a2befab669339f8')
pkgver() {
cd $srcdir/$pkgname
@@ -57,7 +56,7 @@ prepare() {
patch -Np1 < $srcdir/python2-fix.patch
}
-# NOTE: libHTTPDFaust requires 'liblo', 'libmicrohttpd' and 'openssl'.
+# NOTE: libHTTPDFaust requires 'libmicrohttpd' and 'openssl'.
# Similarly, sound2faust requires libsndfile which we also include by default.
# These are all optional, so you can get rid of the extra dependencies by
# changing the build target from 'world' to 'all' and removing the
@@ -74,6 +73,9 @@ package() {
cd $srcdir/$pkgname
make install PREFIX=/usr DESTDIR="$pkgdir"
+ # get rid of some junk that's only needed on iOS
+ rm -rf "$pkgdir/usr/share/faust/osclib"
+
# docs
install -d "$pkgdir/usr/share/doc/faust"
for x in documentation/*.{pdf,html} libraries/doc/*.{pdf,html}; do test -f $x && install -Dm644 $x "$pkgdir/usr/share/doc/faust"; done
@@ -99,5 +101,5 @@ package() {
# emacs
install -d "$pkgdir/usr/share/emacs/site-lisp/"
- install -Dm644 "$srcdir/emacs-faust-mode/faust-mode.el" "$pkgdir/usr/share/emacs/site-lisp/"
+ install -Dm644 faust-mode.el "$pkgdir/usr/share/emacs/site-lisp/"
}
diff --git a/python2-fix.patch b/python2-fix.patch
index 81e932f38a56..dcb473d7b02f 100644
--- a/python2-fix.patch
+++ b/python2-fix.patch
@@ -8,3 +8,13 @@ index 2e460fcb9..5831a86a9 100755
#---------------------- faust2md -----------------------
# Usage: `faust2md [-t 4] [-c] [-f] foo.dsp > foo.md`
+diff --git a/tools/faust2appls/faust2atomsnippets b/tools/faust2appls/faust2atomsnippets
+index 183436022..989618a30 100755
+--- a/tools/faust2appls/faust2atomsnippets
++++ b/tools/faust2appls/faust2atomsnippets
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ #---------------------- faust2atomsnippets -----------------------
+ # Usage: `faust2atomsnippets *.lib > faust-library.cson`