summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2020-02-05 16:46:28 +0100
committerPhilipp A2020-02-05 16:46:28 +0100
commitcbb7c706383c594a462a3e6a05d4b3d615f2312c (patch)
tree4994a8af6c8e815be3675a53b6767c089ee4d965
downloadaur-cbb7c706383c594a462a3e6a05d4b3d615f2312c.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8731070d8aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-tikzplotlib-git
+ pkgdesc = Convert matplotlib figures into TikZ/PGFPlots
+ pkgver = 0.9.1.r5.gd9f636f
+ pkgrel = 1
+ url = https://github.com/nschloe/tikzplotlib
+ arch = any
+ license = MIT
+ makedepends = python
+ depends = python
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-pillow
+ conflicts = python-matplotlib2tikz
+ replaces = python-matplotlib2tikz
+ source = tikzplotlib::git+https://github.com/nschloe/tikzplotlib.git
+ sha256sums = SKIP
+
+pkgname = python-tikzplotlib-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd122a328faf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/tikzplotlib/
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3571f8a9348
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+pkgname=python-tikzplotlib-git
+pkgver=0.9.1.r5.gd9f636f
+pkgrel=1
+pkgdesc="Convert matplotlib figures into TikZ/PGFPlots"
+url="https://github.com/nschloe/tikzplotlib"
+makedepends=('python')
+depends=('python' 'python-numpy' 'python-matplotlib' 'python-pillow')
+replaces=('python-matplotlib2tikz')
+conflicts=('python-matplotlib2tikz')
+license=('MIT')
+arch=('any')
+source=("tikzplotlib::git+https://github.com/nschloe/tikzplotlib.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd tikzplotlib
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/tikzplotlib"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/tikzplotlib"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}