summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisjbillington2021-09-18 20:57:12 +1000
committerchrisjbillington2021-09-18 20:57:12 +1000
commitcbc49d2fd7cf599192cf42be6e822caca3a0bcb5 (patch)
tree3a30a9c995129eeefa24e7ea0cd7a5fae5d617a6
parente150abb5f7bb388ff8605b85a1f2d48e08b65acb (diff)
downloadaur-cbc49d2fd7cf599192cf42be6e822caca3a0bcb5.tar.gz
Add xfwm4 theme
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 21 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96f7f0bbab56..558d641a0b90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yaru-git
pkgdesc = Yaru default ubuntu theme
- pkgver = 21.10.1.r9.g0d9c70b4c
+ pkgver = 21.10.1.r50.g670a52f26
pkgrel = 1
epoch = 1
url = https://github.com/ubuntu/yaru
@@ -40,6 +40,11 @@ pkgname = yaru-gnome-shell-theme-git
provides = yaru-gnome-shell-theme
conflicts = yaru-gnome-shell-theme
+pkgname = yaru-xfwm4-theme-git
+ pkgdesc = Yaru default ubuntu xfwm4 theme
+ provides = yaru-xfwm4-theme
+ conflicts = yaru-xfwm4-theme
+
pkgname = yaru-unity-theme-git
pkgdesc = Yaru default ubuntu unity theme
provides = yaru-unity-theme
diff --git a/PKGBUILD b/PKGBUILD
index de114da87ace..f0380b19af3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,12 @@ pkgname=(yaru-sound-theme-git
yaru-gtk-theme-git
yaru-gtksourceview-theme-git
yaru-gnome-shell-theme-git
+ yaru-xfwm4-theme-git
yaru-unity-theme-git
yaru-metacity-theme-git
yaru-icon-theme-git
yaru-session-git)
-pkgver=21.10.1.r9.g0d9c70b4c
+pkgver=21.10.1.r50.g670a52f26
pkgrel=1
epoch=1
pkgdesc="Yaru default ubuntu theme"
@@ -30,7 +31,7 @@ pkgver() {
build() {
arch-meson yaru build
- meson configure build -Dubuntu-unity=true
+ meson configure build -Dubuntu-unity=true -Dxfwm4=true
ninja -C build
}
@@ -48,6 +49,9 @@ _delete_all_from_pkgdir_except() {
rm "${pkgdir}"/usr/share/themes/Yaru{,-light}/gnome-shell
rm -r "${pkgdir}"/usr/share/gnome-shell/theme/Yaru{,-light}
fi
+ if [[ "$1" != "xfwm4-theme" ]]; then
+ rm -r "${pkgdir}"/usr/share/themes/Yaru{,-dark}/xfwm4
+ fi
if [[ "$1" != "unity-theme" ]]; then
rm -r "${pkgdir}"/usr/share/themes/Yaru{,-dark}/unity
fi
@@ -102,6 +106,15 @@ package_yaru-gnome-shell-theme-git() {
_delete_all_from_pkgdir_except "gnome-shell-theme"
}
+package_yaru-xfwm4-theme-git() {
+ pkgdesc="Yaru default ubuntu xfwm4 theme"
+ provides=(yaru-xfwm4-theme)
+ conflicts=(yaru-xfwm4-theme)
+
+ DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
+ _delete_all_from_pkgdir_except "xfwm4-theme"
+}
+
package_yaru-unity-theme-git() {
pkgdesc="Yaru default ubuntu unity theme"
provides=(yaru-unity-theme)