summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2020-04-26 09:39:02 +0300
committerAnton Kudelin2020-04-26 09:39:02 +0300
commitcbeb2b615338b5581c467ec654d14385e22b1374 (patch)
tree9680da3d85209769a5548c3ede47c4949ccccd8a
parent0d16fe724af6dc711b57b55e3297709f44de9d17 (diff)
downloadaur-cbeb2b615338b5581c467ec654d14385e22b1374.tar.gz
Updated to 2.2.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD9
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d09a8fabe437..3af32d753918 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = python-gspread-pandas
pkgdesc = A package to easily open an instance of a Google spreadsheet and interact with worksheets through Pandas DataFrames
- pkgver = 2.2.1
+ pkgver = 2.2.3
pkgrel = 1
url = https://github.com/aiguofer/gspread-pandas
arch = any
license = BSD
makedepends = python-setuptools
- depends = python
- source = https://github.com/aiguofer/gspread-pandas/archive/v2.2.1.tar.gz
- sha256sums = 9890daf48795803f166afed0b9b66d7f8d95da36b6180187cb04736b2022b6cd
+ depends = python-gspread
+ depends = python-pandas
+ depends = python-decorator
+ depends = python-future
+ depends = python-google-auth
+ depends = python-google-auth-oauthlib
+ source = python-gspread-pandas-2.2.3.tar.gz::https://github.com/aiguofer/gspread-pandas/archive/v2.2.3.tar.gz
+ sha256sums = 09910b49ac07a008c5deceec642c0efa7de84c1a247b6c0e273287bc0fae29f2
pkgname = python-gspread-pandas
diff --git a/PKGBUILD b/PKGBUILD
index dc4483ac684b..bf659bb6c863 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
_pkgname=gspread-pandas
pkgname=python-$_pkgname
-pkgver=2.2.1
+pkgver=2.2.3
pkgrel=1
pkgdesc='A package to easily open an instance of a Google spreadsheet and interact with worksheets through Pandas DataFrames'
url="https://github.com/aiguofer/$_pkgname"
arch=('any')
license=('BSD')
-depends=('python')
+depends=('python-gspread' 'python-pandas' 'python-decorator' 'python-future'
+ 'python-google-auth' 'python-google-auth-oauthlib')
makedepends=('python-setuptools')
-source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('9890daf48795803f166afed0b9b66d7f8d95da36b6180187cb04736b2022b6cd')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('09910b49ac07a008c5deceec642c0efa7de84c1a247b6c0e273287bc0fae29f2')
build(){
cd "$srcdir/$_pkgname-$pkgver"