summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2023-09-03 22:57:11 -0400
committerredfish2023-09-03 22:59:54 -0400
commitcbfc64782cf09457490d537d256b6ba3ab4712ef (patch)
treee831d47a454bd04edc7676979c920d32d4f82a38
parent47c014163aee1333aa4661615d7801d7b044575b (diff)
downloadaur-cbfc64782cf09457490d537d256b6ba3ab4712ef.tar.gz
update to 1.1.10
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--include-cstdint.patch10
3 files changed, 25 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05454297cf41..fe79a08fb571 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = randomx
pkgdesc = RandomX: The proof of work algorithm based on random code execution
- pkgver = 1.1.8
+ pkgver = 1.1.10
pkgrel = 1
url = https://github.com/tevador/RandomX
arch = x86_64
license = BSD
makedepends = cmake
- source = https://github.com/tevador/RandomX/archive/v1.1.8.tar.gz
- sha256sums = f982a12d18b1d260bef2a1d3c46ae4902975fbf63abb38ca6413c96d1778db3a
+ source = https://github.com/tevador/RandomX/archive/v1.1.10.tar.gz
+ source = include-cstdint.patch
+ sha256sums = 051cee65700a10adef84e7946416068bc805757683378a854a1b168ec18da783
+ sha256sums = 4196ae10b1e0600914282e28a25f0f48a9a87277d2275521d7885214af264dc4
pkgname = randomx
-
diff --git a/PKGBUILD b/PKGBUILD
index add062ba0c76..ffa4825a06e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,23 @@
pkgname=randomx
_name=RandomX
-pkgver=1.1.8
+pkgver=1.1.10
pkgrel=1
pkgdesc="RandomX: The proof of work algorithm based on random code execution"
arch=('x86_64')
url="https://github.com/tevador/RandomX"
license=('BSD')
makedepends=('cmake')
-source=("https://github.com/tevador/RandomX/archive/v${pkgver}.tar.gz")
+source=("https://github.com/tevador/RandomX/archive/v${pkgver}.tar.gz"
+ "include-cstdint.patch")
_blddir=build
+prepare() {
+ cd "$srcdir/${_name}-${pkgver}"
+ patch -p1 -i ../include-cstdint.patch
+}
+
build() {
cd "$srcdir/${_name}-${pkgver}"
mkdir ${_blddir}
@@ -33,4 +39,5 @@ package() {
install -Dm755 "randomx-codegen" "${pkgdir}/usr/bin/randomx-codegen"
}
-sha256sums=('f982a12d18b1d260bef2a1d3c46ae4902975fbf63abb38ca6413c96d1778db3a')
+sha256sums=('051cee65700a10adef84e7946416068bc805757683378a854a1b168ec18da783'
+ '4196ae10b1e0600914282e28a25f0f48a9a87277d2275521d7885214af264dc4')
diff --git a/include-cstdint.patch b/include-cstdint.patch
new file mode 100644
index 000000000000..8e0fe7a71521
--- /dev/null
+++ b/include-cstdint.patch
@@ -0,0 +1,10 @@
+--- a/src/tests/utility.hpp 2023-09-03 22:54:08.717410655 -0400
++++ b/src/tests/utility.hpp 2023-09-03 22:54:23.170791179 -0400
+@@ -30,6 +30,7 @@
+
+ #include <cstring>
+ #include <cstdlib>
++#include <cstdint>
+ #include <iostream>
+ #include <fstream>
+