summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Semkin2019-11-20 02:19:06 +0300
committerIvan Semkin2019-11-20 02:20:09 +0300
commitcc198ffe94831b8819001b90f3cd317e5e0ae051 (patch)
tree37d39d92eb8138d8813c5a3cc6a5c155a586f07d
downloadaur-cc198ffe94831b8819001b90f3cd317e5e0ae051.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
-rw-r--r--fdjamakpfbbddfjaooikfcpapjohcfmg.json3
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be533de7c616
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = chromium-extension-dashlane
+ pkgdesc = The password manager, perfected
+ pkgver = 6.1942.1.0
+ pkgrel = 1
+ url = https://www.dashlane.com
+ arch = any
+ license = CUSTOM
+ makedepends = curl
+ depends = chromium
+ noextract = dashlane.crx
+ source = dashlane.crx::https://clients2.google.com/service/update2/crx?response=redirect&prodversion=78.0&x=id%3Dfdjamakpfbbddfjaooikfcpapjohcfmg%26uc
+ source = fdjamakpfbbddfjaooikfcpapjohcfmg.json
+ sha256sums = SKIP
+ sha256sums = 8470694193e7964b7603f881a3936146f50c5e432c39370578351b039f95ab67
+
+pkgname = chromium-extension-dashlane
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..647a5e4f02fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ivan Semkin (ivan at semkin dot ru)
+
+_extension_name='dashlane'
+_extension_id='fdjamakpfbbddfjaooikfcpapjohcfmg'
+_store_base_url='https://clients2.google.com/service/update2/crx?response=redirect&prodversion=78.0&x=id%3D'
+pkgname="chromium-extension-${_extension_name}"
+pkgver=6.1942.1.0
+pkgrel=1
+pkgdesc='The password manager, perfected'
+license=('CUSTOM')
+arch=('any')
+url='https://www.dashlane.com'
+makedepends=('curl')
+depends=('chromium')
+source=(${_extension_name}.crx::"${_store_base_url}${_extension_id}%26uc"
+ "${_extension_id}.json")
+sha256sums=('SKIP'
+ '8470694193e7964b7603f881a3936146f50c5e432c39370578351b039f95ab67')
+noextract=("${_extension_name}.crx")
+
+pkgver() {
+ cd "${srcdir}"
+ curl -Ls -o /dev/null -w %{url_effective} ${_store_base_url}${_extension_id}%26uc | rev | cut -d/ -f1 | rev | sed -e 's/extension_//g' -e 's/.crx//g' -e 's/_/./g' | sort | tail -n1
+}
+
+prepare() {
+ sed -i "s/\/usr\/lib\/x86_64-linux-gnu/\/usr\/lib\/${CARCH}-linux-gnu/" "${_extension_id}.json"
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm 644 "${_extension_name}.crx" \
+ "${pkgdir}/usr/lib/${CARCH}-linux-gnu/${_extension_name}-chromium/${_extension_name}.crx"
+
+ install -Dm 644 "${_extension_id}.json" \
+ "${pkgdir}/usr/share/chromium/extensions/${_extension_id}.json"
+}
+
diff --git a/fdjamakpfbbddfjaooikfcpapjohcfmg.json b/fdjamakpfbbddfjaooikfcpapjohcfmg.json
new file mode 100644
index 000000000000..12555a135028
--- /dev/null
+++ b/fdjamakpfbbddfjaooikfcpapjohcfmg.json
@@ -0,0 +1,3 @@
+{
+ "external_crx": "/usr/lib/x86_64-linux-gnu/dashlane-chromium/dashlane.crx"
+}