summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Miguel2021-10-10 20:20:51 +0100
committerBruno Miguel2021-10-10 20:20:51 +0100
commitcc1ffa449bb13c7cf0e966070896afe46e09158c (patch)
tree89c6d3a884a874b0b7fd60299aed9c1d5b0c9fc9
downloadaur-cc1ffa449bb13c7cf0e966070896afe46e09158c.tar.gz
first version of the pkgbuild
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD41
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4526c8c0a88e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = poddr-deb
+ pkgdesc = Poddr is an open-source podcast player for Windows, Mac and Linux
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/Sn8z/Poddr
+ arch = x86_64
+ groups =
+ license = GPL3
+ makedepends = unzip
+ makedepends = sed
+ depends = nodejs
+ depends = gtk3
+ depends = nss
+ depends = libxss
+ depends = libxtst
+ depends = xdg-utils
+ depends = util-linux-libs
+ depends = libappindicator-gtk3
+ depends = libsecret
+ provides = poddr
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/Sn8z/Poddr/releases/download/2.0.0/poddr_2.0.0_amd64.deb
+ sha512sums = 512ede696e4c2f42fe78f1714278d2bce00e3db4163fe948d4bfae3b842ddbbfb81a0f54768b9dffba2e1243edba855f4d9c55248663408de63ede5eedfa56a2
+
+pkgname = poddr-deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2eaaab05795
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Bruno Miguel <bruno@userrepository.eu>
+pkgname=poddr-deb
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Poddr is an open-source podcast player for Windows, Mac and Linux"
+arch=("x86_64")
+url="https://github.com/Sn8z/Poddr"
+license=("GPL3")
+groups=("")
+makedepends=("unzip" "sed")
+depends=("nodejs" "gtk3" "nss" "libxss" "libxtst" "xdg-utils" "util-linux-libs" "libappindicator-gtk3" "libsecret")
+provides=("poddr")
+replaces=("poddr-deb")
+options=("!strip" "!emptydirs")
+source=("https://github.com/Sn8z/Poddr/releases/download/${pkgver}/poddr_${pkgver}_amd64.deb")
+sha512sums=('512ede696e4c2f42fe78f1714278d2bce00e3db4163fe948d4bfae3b842ddbbfb81a0f54768b9dffba2e1243edba855f4d9c55248663408de63ede5eedfa56a2')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ # SUID chrome-sandbox for Electron 5+
+ chmod 4755 "${pkgdir}/opt/Poddr/chrome-sandbox" || true
+
+ # Install poddr.desktop to the appropriated folder, so any DE can launch it
+ install -Dm644 "${pkgdir}/usr/share/applications/poddr.desktop" poddr.desktop
+
+ # TODO
+ # find a way to copy the application icons to the correct system folders
+
+ # Update mime and desktop databases
+ update-mime-database /usr/share/mime || true
+ update-desktop-database /usr/share/applications || true
+
+ # Symlink the binary to /usr/bin
+ mkdir $pkgdir/usr/bin
+ #cd "${pkgdir}/usr/bin"
+ ln -s ../../opt/Poddr/poddr poddr
+
+}