summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Shpilkin2019-05-19 12:19:48 +0300
committerAlexander Shpilkin2019-05-19 12:19:48 +0300
commitcc3438195bd4c1ec73f9b60b81bcbaf9ed730683 (patch)
tree603264f7dca06334f9533b58e16d22deb6ff6c17
downloadaur-cc3438195bd4c1ec73f9b60b81bcbaf9ed730683.tar.gz
Release version 0.2.1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33163dfe8bb8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-hattifnatt
+ pkgdesc = Push directory to Telegram channel
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/alexshpilkin/hattifnatt
+ arch = any
+ license = custom:CC0
+ makedepends = python-setuptools
+ depends = python>=3.5
+ depends = python-pathtools>=0.1.2
+ depends = python-telegram-bot>=10.0.2
+ depends = python-watchdog>=0.9.0
+ source = https://github.com/alexshpilkin/hattifnatt/releases/download/v0.2.1/hattifnatt-0.2.1.tar.gz
+ source = https://github.com/alexshpilkin/hattifnatt/releases/download/v0.2.1/hattifnatt-0.2.1.tar.gz.asc
+ validpgpkeys = B595D74D6615C010469F5A1373E9AA114B3A894B
+ sha256sums = 4f10ff1f1e29590ce4bc25c7bbeecb5778bf4732118294543f0632cdc9139830
+ sha256sums = SKIP
+
+pkgname = python-hattifnatt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5540be98fe46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Alexander Shpilkin <ashpilkin@gmail.com>
+
+pkgname=python-hattifnatt
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Push directory to Telegram channel"
+url="https://github.com/alexshpilkin/hattifnatt"
+arch=('any')
+license=('custom:CC0')
+depends=('python>=3.5'
+ 'python-pathtools>=0.1.2'
+ 'python-telegram-bot>=10.0.2'
+ 'python-watchdog>=0.9.0')
+makedepends=('python-setuptools')
+source=("https://github.com/alexshpilkin/hattifnatt/releases/download/v$pkgver/hattifnatt-$pkgver.tar.gz"
+ "https://github.com/alexshpilkin/hattifnatt/releases/download/v$pkgver/hattifnatt-$pkgver.tar.gz.asc")
+sha256sums=('4f10ff1f1e29590ce4bc25c7bbeecb5778bf4732118294543f0632cdc9139830'
+ 'SKIP')
+validpgpkeys=('B595D74D6615C010469F5A1373E9AA114B3A894B')
+
+build() {
+ cd "hattifnatt-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "hattifnatt-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}