summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Sabota2019-06-20 14:28:10 -0400
committerLukas Sabota2019-06-20 14:28:10 -0400
commitcc5178d7160e645c5c555fe7ae949e14abdcbded (patch)
tree6f066662769e65acb46bdc40fa17d65fcf07791a
parent70c572a5740b9bd69fc83622882320bee4ebfa3d (diff)
downloadaur-cc5178d7160e645c5c555fe7ae949e14abdcbded.tar.gz
use fedora's patch for gcc9
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4a98958c3bf..04021179ca85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Tue Dec 15 03:37:13 UTC 2015
pkgbase = lib32-glib
pkgdesc = Common C routines used by Gtk+ and other libs (32-bit)
pkgver = 1.2.10
- pkgrel = 1
+ pkgrel = 2
url = http://www.gtk.org/
install = glib.install
arch = x86_64
@@ -13,10 +11,12 @@ pkgbase = lib32-glib
depends = sh
options = !makeflags
source = ftp://ftp.gnome.org/pub/gnome/sources/glib/1.2/glib-1.2.10.tar.gz
+ source = https://src.fedoraproject.org/rpms/glib/raw/master/f/glib-1.2.10-gcc9.patch
source = gcc340.patch
source = aclocal-fixes.patch
source = glib1-autotools.patch
sha1sums = e5a9361c594608d152d5d9650154c2e3260b87fa
+ sha1sums = 9e675101003cd97da0b42bf04fc6489197a822c7
sha1sums = a2cc224a66aeffdcac16ebd9e8af18143cf54918
sha1sums = ae4438cf56c0c9264ee36f6973fb445f9a820be0
sha1sums = 8a25fde3c79567262b3024f4e74c9ca4ee8a6279
diff --git a/PKGBUILD b/PKGBUILD
index 5e7b9e565470..fe0fbc243e35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=glib
pkgname=lib32-glib
pkgver=1.2.10
-pkgrel=1
+pkgrel=2
pkgdesc="Common C routines used by Gtk+ and other libs (32-bit)"
arch=('x86_64')
url="http://www.gtk.org/"
@@ -14,8 +14,10 @@ makedepends=('gcc-multilib')
options=('!makeflags')
install=glib.install
source=(ftp://ftp.gnome.org/pub/gnome/sources/glib/1.2/${_pkgname}-${pkgver}.tar.gz
+ https://src.fedoraproject.org/rpms/glib/raw/master/f/glib-1.2.10-gcc9.patch
gcc340.patch aclocal-fixes.patch glib1-autotools.patch)
sha1sums=('e5a9361c594608d152d5d9650154c2e3260b87fa'
+ '9e675101003cd97da0b42bf04fc6489197a822c7'
'a2cc224a66aeffdcac16ebd9e8af18143cf54918'
'ae4438cf56c0c9264ee36f6973fb445f9a820be0'
'8a25fde3c79567262b3024f4e74c9ca4ee8a6279')
@@ -23,6 +25,7 @@ sha1sums=('e5a9361c594608d152d5d9650154c2e3260b87fa'
prepare() {
cd ${_pkgname}-${pkgver}
patch -Np1 -i "${srcdir}/gcc340.patch"
+ patch -Np0 -i "${srcdir}/glib-1.2.10-gcc9.patch"
patch -Np0 -i "${srcdir}/aclocal-fixes.patch"
patch -Np1 -i "${srcdir}/glib1-autotools.patch"
sed -i -e 's/ifdef[[:space:]]*__OPTIMIZE__/if 0/' glib.h