summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruli2023-10-26 21:42:59 +0200
committeruli2023-10-26 21:43:30 +0200
commitcc62562f0183c68c6c2ce1c12920de3b00db7fc7 (patch)
tree378909fd15991694b410be9b517c5b178abfc248
parentd0d0f9726661dfec347725c0201bf723ebfec2a1 (diff)
downloadaur-cc62562f0183c68c6c2ce1c12920de3b00db7fc7.tar.gz
v5.8.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--plugin.patch25
3 files changed, 38 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4dd8b5217508..8be7c282d9ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opencpn
pkgdesc = Open Source Chart Plotting / Marine Navigation
- pkgver = 5.8.2
+ pkgver = 5.8.4
pkgrel = 1
url = http://opencpn.org
arch = x86_64
@@ -19,7 +19,9 @@ pkgbase = opencpn
depends = webkit2gtk
depends = wxsvg
optdepends = gpsd: GPS position support
- source = opencpn-5.8.2.tar.gz::https://github.com/OpenCPN/OpenCPN/archive/Release_5.8.2.tar.gz
- b2sums = ecce27972a00af412283923a1720b9d74c80905101f383815e801691ab9dacb7c60328f6cd597811d4538bccf383e66465e08e2094420187272298151327b717
+ source = opencpn-5.8.4.tar.gz::https://github.com/OpenCPN/OpenCPN/archive/Release_5.8.4.tar.gz
+ source = plugin.patch
+ b2sums = 0235d87daec97008b58dc9916d4250b33c0c4158be6ba4853bf30c5876af7d382eb1c02e2cd3748229775305cc90f86d5743b9951909043588e2096fcd207af5
+ b2sums = 66a83b2ef79ce903884d1d072a5e4f8c6db557b2566fa1c50b82b4435cdbf787116c6b9f6d590e9240ca0c8bc06794ac5d9245e7ef18a2c03869f808c51582a6
pkgname = opencpn
diff --git a/PKGBUILD b/PKGBUILD
index 9596690e9af3..1781e238d8d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Submitter: Anders Lund <anders at alweb dot dk>
pkgname=opencpn
-pkgver=5.8.2
+pkgver=5.8.4
pkgrel=1
pkgdesc="Open Source Chart Plotting / Marine Navigation"
arch=('x86_64' 'aarch64')
@@ -16,8 +16,13 @@ depends=('wxgtk3' 'portaudio' 'tinyxml' 'libsndfile' 'libarchive' 'libexif' 'gle
optdepends=('gpsd: GPS position support')
makedepends=('cmake' 'lsb-release')
url="http://opencpn.org"
-source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenCPN/OpenCPN/archive/Release_${pkgver}.tar.gz")
-b2sums=('ecce27972a00af412283923a1720b9d74c80905101f383815e801691ab9dacb7c60328f6cd597811d4538bccf383e66465e08e2094420187272298151327b717')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenCPN/OpenCPN/archive/Release_${pkgver}.tar.gz" "plugin.patch")
+b2sums=('0235d87daec97008b58dc9916d4250b33c0c4158be6ba4853bf30c5876af7d382eb1c02e2cd3748229775305cc90f86d5743b9951909043588e2096fcd207af5' '66a83b2ef79ce903884d1d072a5e4f8c6db557b2566fa1c50b82b4435cdbf787116c6b9f6d590e9240ca0c8bc06794ac5d9245e7ef18a2c03869f808c51582a6')
+
+prepare() {
+ cd OpenCPN-Release_${pkgver}
+ patch --strip=1 --input=../plugin.patch
+}
build() {
cd OpenCPN-Release_${pkgver}
diff --git a/plugin.patch b/plugin.patch
new file mode 100644
index 000000000000..e9b70963650e
--- /dev/null
+++ b/plugin.patch
@@ -0,0 +1,25 @@
+--- a/src/plugin_loader.cpp
++++ b/src/plugin_loader.cpp
+@@ -317,14 +317,14 @@
+ if (!base_plugin_path.EndsWith(wxFileName::GetPathSeparator()))
+ base_plugin_path += wxFileName::GetPathSeparator();
+
+- if (!g_bportable){
+- if (base_plugin_path.IsSameAs(plugin_file_path)){
+- if (!IsSystemPlugin(file_name.ToStdString())){
+- DEBUG_LOG << "Skipping plugin " << file_name << " in " << g_BasePlatform->GetPluginDir();
+- return false;
+- }
+- }
+- }
++ // if (!g_bportable){
++ // if (base_plugin_path.IsSameAs(plugin_file_path)){
++ // if (!IsSystemPlugin(file_name.ToStdString())){
++ // DEBUG_LOG << "Skipping plugin " << file_name << " in " << g_BasePlatform->GetPluginDir();
++ // return false;
++ // }
++ // }
++ // }
+
+ if (!IsSystemPlugin(file_name.ToStdString()) && safe_mode::get_mode()) {
+ DEBUG_LOG << "Skipping plugin " << file_name << " in safe mode";