summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2019-01-17 20:34:45 +0100
committerKr1ss2019-01-17 20:34:45 +0100
commitcca7a2386e2e34e0782d4296e5673d56709b63bd (patch)
tree613a367182f947a592c57db6fa76105cca0296cd
downloadaur-cca7a2386e2e34e0782d4296e5673d56709b63bd.tar.gz
initial upload: 7.7.9.r3.75158666e-1
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD50
-rw-r--r--seautomate3
-rw-r--r--seautomate.sigbin0 -> 566 bytes
-rw-r--r--seproxy3
-rw-r--r--seproxy.sigbin0 -> 566 bytes
-rw-r--r--setoolkit3
-rw-r--r--setoolkit.sigbin0 -> 566 bytes
8 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4afd4efef534
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = social-engineer-toolkit-git
+ pkgdesc = The Social-Engineer Toolkit (SET) - Development Version
+ pkgver = 7.7.9.r3.75158666e
+ pkgrel = 1
+ url = https://github.com/trustedsec/social-engineer-toolkit
+ arch = any
+ license = custom
+ makedepends = python2
+ depends = python2-pexpect
+ depends = python2-crypto
+ depends = python2-requests
+ depends = python2-pyopenssl
+ depends = python2-pefile
+ depends = impacket
+ depends = python2-pillow
+ depends = python2-qrcode
+ depends = python2-beautifulsoup4
+ optdepends = metasploit
+ provides = social-engineer-toolkit
+ conflicts = social-engineer-toolkit
+ options = !strip
+ source = git+https://github.com/trustedsec/social-engineer-toolkit.git
+ source = setoolkit
+ source = setoolkit.sig
+ source = seproxy
+ source = seproxy.sig
+ source = seautomate
+ source = seautomate.sig
+ validpgpkeys = 7A194E3F7A8F867BEA8A5339023F078862ACFE50
+ sha256sums = SKIP
+ sha256sums = 1901a912bc8fcc24b8a63accaa3824b50dae5f7066dbdfa83f6f9ee3e3dfdb65
+ sha256sums = SKIP
+ sha256sums = 12014216d4249ee76b30126ab3e78862b79cab32fe663b382a579b18350a536f
+ sha256sums = SKIP
+ sha256sums = 18976b6e8a83e158b9ca175dfebe1e98fc4085129a0b20064ec54e0bc5eda1d9
+ sha256sums = SKIP
+
+pkgname = social-engineer-toolkit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c6ded872abf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Kr1ss <kr1ss.x@yandex.com>
+
+pkgname=social-engineer-toolkit-git
+pkgver=7.7.9.r3.75158666e
+pkgrel=1
+pkgdesc="The Social-Engineer Toolkit (SET) - Development Version"
+arch=("any")
+url="https://github.com/trustedsec/${pkgname%-git}"
+license=("custom")
+makedepends=("python2")
+depends=("python2-pexpect" "python2-crypto" "python2-requests"
+ "python2-pyopenssl" "python2-pefile" "impacket"
+ "python2-pillow" "python2-qrcode" "python2-beautifulsoup4")
+optdepends=("metasploit")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+options=('!strip')
+source=("git+https://github.com/trustedsec/${pkgname%-git}.git"
+ "setoolkit"{,.sig}
+ "seproxy"{,.sig}
+ "seautomate"{,.sig})
+sha256sums=('SKIP'
+ '1901a912bc8fcc24b8a63accaa3824b50dae5f7066dbdfa83f6f9ee3e3dfdb65'
+ 'SKIP'
+ '12014216d4249ee76b30126ab3e78862b79cab32fe663b382a579b18350a536f'
+ 'SKIP'
+ '18976b6e8a83e158b9ca175dfebe1e98fc4085129a0b20064ec54e0bc5eda1d9'
+ 'SKIP')
+validpgpkeys=('7A194E3F7A8F867BEA8A5339023F078862ACFE50')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ python2 -m compileall .
+ python2 -O -m compileall .
+}
+
+package() {
+ install -dm755 "${pkgdir}"/usr/{bin,share/{,doc/,licenses/}setoolkit}
+ install -m755 setoolkit seproxy seautomate "${pkgdir}"/usr/bin/
+ cd "${pkgname%-git}"
+ install -m644 readme/LICENSE "${pkgdir}"/usr/share/licenses/setoolkit/
+ install -m644 readme/* "${pkgdir}"/usr/share/doc/setoolkit/
+ cp -r * "${pkgdir}"/usr/share/setoolkit/
+}
+
diff --git a/seautomate b/seautomate
new file mode 100644
index 000000000000..6c160920ad5e
--- /dev/null
+++ b/seautomate
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/setoolkit
+exec python2 seautomate "$@"
diff --git a/seautomate.sig b/seautomate.sig
new file mode 100644
index 000000000000..6cef6492f53e
--- /dev/null
+++ b/seautomate.sig
Binary files differ
diff --git a/seproxy b/seproxy
new file mode 100644
index 000000000000..8fb4c3d54981
--- /dev/null
+++ b/seproxy
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/setoolkit
+exec python2 seproxy
diff --git a/seproxy.sig b/seproxy.sig
new file mode 100644
index 000000000000..d68b60704196
--- /dev/null
+++ b/seproxy.sig
Binary files differ
diff --git a/setoolkit b/setoolkit
new file mode 100644
index 000000000000..2c5afc7227aa
--- /dev/null
+++ b/setoolkit
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/setoolkit
+exec python2 setoolkit
diff --git a/setoolkit.sig b/setoolkit.sig
new file mode 100644
index 000000000000..5aa21502a340
--- /dev/null
+++ b/setoolkit.sig
Binary files differ