summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Sinclair2017-01-08 16:52:43 -0500
committerAdrian Sinclair2017-01-08 16:52:43 -0500
commitccb28acff7d859fc2fd3ccc77f424f06cc0845f7 (patch)
treeb0c5cd5a0fc3f79b8b0b1d119c3d5b6e4e6c6656
downloadaur-ccb28acff7d859fc2fd3ccc77f424f06cc0845f7.tar.gz
create package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3da03dd2a7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = eslint-plugin-react
+ pkgdesc = React specific linting rules for ESLint
+ pkgver = 6.8.0
+ pkgrel = 1
+ url = https://github.com/yannickcr/eslint-plugin-react
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ noextract = eslint-plugin-react-6.8.0.tgz
+ source = http://registry.npmjs.org/eslint-plugin-react/-/eslint-plugin-react-6.8.0.tgz
+ md5sums = SKIP
+
+pkgname = eslint-plugin-react
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8038fac48b7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Adrian Sinclair <adrian@transloadit.com>
+
+pkgname=eslint-plugin-react
+pkgver=6.8.0
+pkgrel=1
+pkgdesc='React specific linting rules for ESLint'
+arch=('any')
+url='https://github.com/yannickcr/eslint-plugin-react'
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+source=(http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
+noextract=($pkgname-$pkgver.tgz)
+md5sums=('SKIP')
+
+package() {
+ npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/$pkgname-$pkgver.tgz
+ rm -r "$pkgdir"/usr/etc
+
+ # Fix permissions
+ find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s ../../../lib/node_modules/$pkgname/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}