summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Le Moal2015-06-21 18:15:58 +0200
committerOlivier Le Moal2015-06-21 18:15:58 +0200
commitccd19b42e6003b4a0271a9dba342aa008259672e (patch)
tree337c3fa92f44c9fb996edd0b1ef951b0782e98c8
downloadaur-ccd19b42e6003b4a0271a9dba342aa008259672e.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa90eb23bf6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mfoc
+ pkgdesc = Mifare Classic Offline Cracker
+ pkgver = 0.10.7
+ pkgrel = 2
+ url = https://github.com/nfc-tools/mfoc
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = libnfc>=1.7.0
+ source = https://github.com/nfc-tools/mfoc/archive/mfoc-0.10.7.tar.gz
+ sha1sums = 4df9fee7a1cbbc5b25b4a5db53a192325b132805
+
+pkgname = mfoc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f094544947b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Olivier LM <mail at olivierlemoal dot fr>
+# Contributor: Pascal E. <archlinux at hardfalcon dot net>
+# Contributor: Andrej Gelenberg <andrej.gelenberg at udo dot edu>
+pkgname=mfoc
+pkgver=0.10.7
+pkgrel=2
+pkgdesc="Mifare Classic Offline Cracker"
+arch=('i686' 'x86_64')
+url="https://github.com/nfc-tools/mfoc"
+license=('GPL2')
+depends=("libnfc>=1.7.0")
+source=("https://github.com/nfc-tools/mfoc/archive/$pkgname-$pkgver.tar.gz")
+
+sha1sums=('4df9fee7a1cbbc5b25b4a5db53a192325b132805')
+
+package()
+{
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+build()
+{
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
+ autoreconf -vis
+ ./configure --prefix=/usr
+ make
+}