summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2017-12-11 23:56:31 +0100
committerEduardo Sánchez Muñoz2017-12-11 23:56:31 +0100
commitccf1948ba706abdda91ae5bfd6b9bd3f090d1086 (patch)
tree1f88b5b423f7fd86b4e14e32144164fcb92f7f56
parent09140174befab62477ccf6678172a12eb308383e (diff)
downloadaur-ccf1948ba706abdda91ae5bfd6b9bd3f090d1086.tar.gz
Update to version 1.2.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD35
-rw-r--r--aur-fixes.diff67
4 files changed, 74 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2abfb7df4a04..73e7bba112f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Nov 21 15:14:21 UTC 2017
+# Mon Dec 11 22:56:22 UTC 2017
pkgbase = telegram-desktop
pkgdesc = Official desktop version of Telegram messaging app.
- pkgver = 1.1.23
- pkgrel = 2
+ pkgver = 1.2.0
+ pkgrel = 1
url = https://desktop.telegram.org/
arch = i686
arch = x86_64
@@ -16,6 +16,7 @@ pkgbase = telegram-desktop
makedepends = libexif
makedepends = libwebp
makedepends = google-breakpad-git
+ makedepends = range-v3
makedepends = chrpath
makedepends = cmake
makedepends = python
@@ -54,10 +55,13 @@ pkgbase = telegram-desktop
depends = xcb-util-renderutil
depends = hicolor-icon-theme
depends = openssl-1.0
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.1.23
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.2.0
source = GSL::git+https://github.com/Microsoft/GSL.git
source = variant::git+https://github.com/mapbox/variant.git
source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git
+ source = git+https://github.com/telegramdesktop/fcitx.git#commit=1abe0b8bdf8124a49f63ddf90de78ed10748c2f6
+ source = git+https://github.com/telegramdesktop/hime.git#commit=28f674788a6ba940296ec77c14a2a9f7f0e4618a
+ source = qt5_6_2::git+https://code.qt.io/qt/qt5.git#tag=v5.6.2
source = https://download.qt.io/official_releases/qt/5.6/5.6.2/submodules/qtbase-opensource-src-5.6.2.tar.xz
source = https://download.qt.io/official_releases/qt/5.6/5.6.2/submodules/qtimageformats-opensource-src-5.6.2.tar.xz
source = https://download.qt.io/official_releases/qt/5.6/5.6.2/submodules/qtwayland-opensource-src-5.6.2.tar.xz
@@ -70,13 +74,16 @@ pkgbase = telegram-desktop
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 2f6eae93c5d982fe0a387a01aeb3435571433e23e9d9d9246741faf51f1ee787
sha256sums = 4fb153be62dac393cbcebab65040b3b9d6edecd1ebbe5e543401b0e45bd147e4
sha256sums = 035c3199f4719627b64b7020f0f4574da2b4cb78c6981aba75f27b872d8e6c86
sha256sums = SKIP
sha256sums = f47f4b10c8b498ab456ad1dd54754cbd6725b936bb94ffe4fea12d2c2f2b408d
sha256sums = d4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb
- sha256sums = 5bd1272ba8221eeb1d26b1673093f726e8bf028b1c867b814cd3c552a8a59a36
+ sha256sums = 5ff20e8b76661c9c1f4abe06eaf8fc40b93a9af273880f62e2ae0c5bd172957f
sha256sums = df86ab21e5eddc3dac46781a2165452ce076e928c2b9d59f340883c13f5d5a02
pkgname = telegram-desktop
diff --git a/.gitignore b/.gitignore
index 914026cd96b4..778e034a6b6a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,6 +4,9 @@
/GSL
/variant
/libtgvoip
+/fcitx
+/hime
+/qt*
/gyp
/pkg
/src
diff --git a/PKGBUILD b/PKGBUILD
index 4dd5bc0782e3..7877f6127870 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=telegram-desktop
-pkgver=1.1.23
-pkgrel=2
+pkgver=1.2.0
+pkgrel=1
pkgdesc='Official desktop version of Telegram messaging app.'
arch=('i686' 'x86_64')
url="https://desktop.telegram.org/"
@@ -31,6 +31,7 @@ makedepends=(
'libexif'
'libwebp'
'google-breakpad-git'
+ 'range-v3'
'chrpath'
'cmake'
'python'
@@ -65,6 +66,9 @@ source=(
"GSL::git+https://github.com/Microsoft/GSL.git"
"variant::git+https://github.com/mapbox/variant.git"
"libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git"
+ "git+https://github.com/telegramdesktop/fcitx.git#commit=1abe0b8bdf8124a49f63ddf90de78ed10748c2f6"
+ "git+https://github.com/telegramdesktop/hime.git#commit=28f674788a6ba940296ec77c14a2a9f7f0e4618a"
+ "qt${qt_version//./_}::git+https://code.qt.io/qt/qt5.git#tag=v$qt_version"
"https://download.qt.io/official_releases/qt/${qt_version%.*}/$qt_version/submodules/qtbase-opensource-src-$qt_version.tar.xz"
"https://download.qt.io/official_releases/qt/${qt_version%.*}/$qt_version/submodules/qtimageformats-opensource-src-$qt_version.tar.xz"
"https://download.qt.io/official_releases/qt/${qt_version%.*}/$qt_version/submodules/qtwayland-opensource-src-$qt_version.tar.xz"
@@ -79,13 +83,16 @@ sha256sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'2f6eae93c5d982fe0a387a01aeb3435571433e23e9d9d9246741faf51f1ee787'
'4fb153be62dac393cbcebab65040b3b9d6edecd1ebbe5e543401b0e45bd147e4'
'035c3199f4719627b64b7020f0f4574da2b4cb78c6981aba75f27b872d8e6c86'
'SKIP'
'f47f4b10c8b498ab456ad1dd54754cbd6725b936bb94ffe4fea12d2c2f2b408d'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb'
- '5bd1272ba8221eeb1d26b1673093f726e8bf028b1c867b814cd3c552a8a59a36'
+ '5ff20e8b76661c9c1f4abe06eaf8fc40b93a9af273880f62e2ae0c5bd172957f'
'df86ab21e5eddc3dac46781a2165452ce076e928c2b9d59f340883c13f5d5a02'
)
@@ -98,16 +105,23 @@ prepare() {
local qt_src_dir="$srcdir/Libraries/qt${qt_version//./_}"
if [ "$qt_patch_file" -nt "$qt_src_dir" ]; then
rm -rf "$qt_src_dir"
- mkdir "$qt_src_dir"
+ mv "$srcdir/qt${qt_version//./_}" "$qt_src_dir"
+ cd "$qt_src_dir"
+ rmdir "$qt_src_dir/qtbase"
mv "$srcdir/qtbase-opensource-src-$qt_version" "$qt_src_dir/qtbase"
+ rmdir "$qt_src_dir/qtimageformats"
mv "$srcdir/qtimageformats-opensource-src-$qt_version" "$qt_src_dir/qtimageformats"
+ rmdir "$qt_src_dir/qtwayland"
mv "$srcdir/qtwayland-opensource-src-$qt_version" "$qt_src_dir/qtwayland"
cd "$qt_src_dir/qtbase"
patch -p1 -i "$qt_patch_file"
echo "INCLUDEPATH += /usr/include/openssl-1.0" >> "$qt_src_dir/qtbase/src/network/network.pro"
+
+ mv "$srcdir/fcitx" "$qt_src_dir/qtbase/src/plugins/platforminputcontexts/fcitx"
+ mv "$srcdir/hime" "$qt_src_dir/qtbase/src/plugins/platforminputcontexts/hime"
fi
cd "$srcdir/gyp"
@@ -138,7 +152,7 @@ build() {
local qt_src_dir="$srcdir/Libraries/qt${qt_version//./_}"
export OPENSSL_LIBS='-L/usr/lib/openssl-1.0 -lssl -lcrypto'
- cd "$qt_src_dir/qtbase"
+ cd "$qt_src_dir"
./configure \
-prefix "$srcdir/qt" \
-release \
@@ -160,17 +174,6 @@ build() {
#-no-opengl
make
make install
- export PATH="$srcdir/qt/bin:$PATH"
-
- cd "$qt_src_dir/qtimageformats"
- qmake .
- make
- make install
-
- cd "$qt_src_dir/qtwayland"
- qmake .
- make
- make install
# Build Telegram Desktop
rm -rf "$srcdir/tdesktop/out"
diff --git a/aur-fixes.diff b/aur-fixes.diff
index e92c3c1fbb00..48f7dbadf013 100644
--- a/aur-fixes.diff
+++ b/aur-fixes.diff
@@ -11,10 +11,10 @@ index b975c7a8..5ad461a4 100644
Q_IMPORT_PLUGIN(QGenericEnginePlugin)
Q_IMPORT_PLUGIN(QNetworkManagerEnginePlugin)
diff --git a/Telegram/gyp/Telegram.gyp b/Telegram/gyp/Telegram.gyp
-index 0d1f38aa..0665cce1 100644
+index 31480945..193690e8 100644
--- a/Telegram/gyp/Telegram.gyp
+++ b/Telegram/gyp/Telegram.gyp
-@@ -85,25 +85,21 @@
+@@ -87,25 +87,21 @@
],
'defines': [
@@ -32,11 +32,11 @@ index 0d1f38aa..0665cce1 100644
'<(SHARED_INTERMEDIATE_DIR)',
- '<(libs_loc)/breakpad/src',
- '<(libs_loc)/lzma/C',
-- '<(libs_loc)/libexif-0.6.20',
-- '<(libs_loc)/zlib-1.2.8',
+- '<(libs_loc)/zlib',
- '<(libs_loc)/ffmpeg',
- '<(libs_loc)/openal-soft/include',
- '<(libs_loc)/opus/include',
+- '<(libs_loc)/range-v3/include',
'<(minizip_loc)',
'<(sp_media_key_tap_loc)',
'<(emoji_suggestions_loc)',
@@ -44,8 +44,21 @@ index 0d1f38aa..0665cce1 100644
'<(submodules_loc)/GSL/include',
'<(submodules_loc)/variant/include',
],
+diff --git a/Telegram/gyp/linux_glibc_wraps.gyp b/Telegram/gyp/linux_glibc_wraps.gyp
+index 07a8276f..99ac4cac 100644
+--- a/Telegram/gyp/linux_glibc_wraps.gyp
++++ b/Telegram/gyp/linux_glibc_wraps.gyp
+@@ -27,7 +27,7 @@
+ 'sources': [
+ '../SourceFiles/platform/linux/linux_glibc_wraps.c',
+ ],
+- 'conditions': [[ '"<!(uname -p)" == "x86_64"', {
++ 'conditions': [[ '"<!(uname -m)" == "x86_64"', {
+ 'sources': [
+ '../SourceFiles/platform/linux/linux_glibc_wraps_64.c',
+ ],
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
-index 6032d066..567cdb95 100644
+index dea127a3..57106533 100644
--- a/Telegram/gyp/qt.gypi
+++ b/Telegram/gyp/qt.gypi
@@ -38,7 +38,6 @@
@@ -74,13 +87,13 @@ index 6032d066..567cdb95 100644
- 'xcb-xfixes',
- 'xcb-render',
- 'xcb-static',
-+ 'Qt5WaylandClient',
+ 'qwayland-generic',
+ 'qwayland-egl',
++ 'Qt5WaylandClient',
],
}],
],
-@@ -200,6 +188,7 @@
+@@ -201,6 +189,7 @@
'<(qt_loc)/include/QtGui/<(qt_version)',
'<(qt_loc)/include/QtCore/<(qt_version)/QtCore',
'<(qt_loc)/include/QtGui/<(qt_version)/QtGui',
@@ -88,15 +101,15 @@ index 6032d066..567cdb95 100644
],
'library_dirs': [
'<(qt_loc)/lib',
-@@ -220,7 +209,6 @@
- '<(qt_loc)/plugins/platforminputcontexts',
+@@ -225,7 +214,6 @@
],
'libraries': [
+ '<(PRODUCT_DIR)/obj.target/liblinux_glibc_wraps.a',
- '<(linux_path_xkbcommon)/lib/libxkbcommon.a',
'<@(qt_libs_release)',
'<(linux_lib_ssl)',
'<(linux_lib_crypto)',
-@@ -233,12 +221,32 @@
+@@ -238,12 +226,32 @@
'-lgthread-2.0',
'-lglib-2.0',
'-lpthread',
@@ -128,27 +141,27 @@ index 6032d066..567cdb95 100644
'ldflags': [
- '-static-libstdc++',
'-pthread',
- '-g',
'-rdynamic',
+ ],
diff --git a/Telegram/gyp/settings_linux.gypi b/Telegram/gyp/settings_linux.gypi
-index fde88dcd..1fd1b9cb 100644
+index b93bace4..0f14aa1f 100644
--- a/Telegram/gyp/settings_linux.gypi
+++ b/Telegram/gyp/settings_linux.gypi
-@@ -25,7 +25,6 @@
+@@ -24,7 +24,6 @@
+ 'linux_common_flags': [
'-pipe',
- '-g',
'-Wall',
- '-Werror',
'-W',
'-fPIC',
'-Wno-unused-variable',
diff --git a/Telegram/gyp/telegram_linux.gypi b/Telegram/gyp/telegram_linux.gypi
-index 2c464928..2112496b 100644
+index f6918c22..36ef6ad3 100644
--- a/Telegram/gyp/telegram_linux.gypi
+++ b/Telegram/gyp/telegram_linux.gypi
-@@ -21,11 +21,20 @@
- 'conditions': [[ 'build_linux', {
+@@ -22,11 +22,20 @@
'variables': {
+ 'not_need_gtk%': '<!(python -c "print(\'TDESKTOP_DISABLE_GTK_INTEGRATION\' in \'<(build_defines)\')")',
'pkgconfig_libs': [
-# In order to work libxkbcommon must be linked statically,
-# PKGCONFIG links it like "-L/usr/local/lib -lxkbcommon"
@@ -172,8 +185,8 @@ index 2c464928..2112496b 100644
],
'linux_path_ffmpeg%': '/usr/local',
'linux_path_openal%': '/usr/local',
-@@ -36,20 +45,11 @@
- 'linux_path_opus_include%': '<(libs_loc)/opus/include',
+@@ -37,20 +46,11 @@
+ 'linux_path_range%': '/usr/local',
},
'include_dirs': [
- '/usr/local/include',
@@ -181,13 +194,13 @@ index 2c464928..2112496b 100644
- '<(linux_path_openal)/include',
- '<(linux_path_breakpad)/include/breakpad',
'<(linux_path_opus_include)',
+- '<(linux_path_range)/include',
+ '/usr/include',
],
'library_dirs': [
- '/usr/local/lib',
- '<(linux_path_ffmpeg)/lib',
- '<(linux_path_openal)/lib',
-- '<(linux_path_libexif_lib)',
- '<(linux_path_va)/lib',
- '<(linux_path_vdpau)/lib',
- '<(linux_path_breakpad)/lib',
@@ -195,7 +208,7 @@ index 2c464928..2112496b 100644
],
'libraries': [
'breakpad_client',
-@@ -57,27 +57,14 @@
+@@ -58,23 +58,14 @@
'ibusplatforminputcontextplugin',
'fcitxplatforminputcontextplugin',
'himeplatforminputcontextplugin',
@@ -217,11 +230,11 @@ index 2c464928..2112496b 100644
+ '<!(pkg-config 2> /dev/null --libs <@(pkgconfig_libs))',
],
'cflags_cc': [
- '<!(pkg-config 2> /dev/null --cflags appindicator-0.1)',
- '<!(pkg-config 2> /dev/null --cflags gtk+-2.0)',
- '<!(pkg-config 2> /dev/null --cflags glib-2.0)',
- '<!(pkg-config 2> /dev/null --cflags dee-1.0)',
++ '<!(pkg-config 2> /dev/null --cflags appindicator-0.1)',
++ '<!(pkg-config 2> /dev/null --cflags gtk+-2.0)',
++ '<!(pkg-config 2> /dev/null --cflags glib-2.0)',
++ '<!(pkg-config 2> /dev/null --cflags dee-1.0)',
+ '<!(pkg-config 2> /dev/null --cflags <@(pkgconfig_libs))',
+ '-Wno-strict-overflow',
],
- 'configurations': {
- 'Release': {
+ 'ldflags': [