summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenaud LITTOLFF2018-11-05 12:11:16 +0100
committerRenaud LITTOLFF2018-11-05 12:11:16 +0100
commitccfcdff9840d19719fd571791aa0af0711c647ae (patch)
tree2ba0c9b3390f3d269d82ab0de0c54ca1597538bc
downloadaur-ccfcdff9840d19719fd571791aa0af0711c647ae.tar.gz
Add icu62 lib
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01cdc795a465
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = icu62
+ pkgdesc = International Components for Unicode library
+ pkgver = 62.1
+ pkgrel = 1
+ url = http://www.icu-project.org/
+ arch = i686
+ arch = x86_64
+ license = custom:"icu"
+ depends = gcc-libs>=4.7.1-5
+ source = http://download.icu-project.org/files/icu4c/62.1/icu4c-62_1-src.tgz
+ md5sums = 490ad9d920158e0314e10ba74ae9a150
+
+pkgname = icu62
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6d80f01e658
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Author: marmotz <rlittolff@gmail.com>
+
+_pkgname=icu
+pkgname=${_pkgname}62
+pkgver=62.1
+pkgrel=1
+pkgdesc="International Components for Unicode library"
+arch=('i686' 'x86_64')
+url="http://www.icu-project.org/"
+license=('custom:"icu"')
+depends=('gcc-libs>=4.7.1-5')
+source=(http://download.icu-project.org/files/${_pkgname}4c/${pkgver}/${_pkgname}4c-${pkgver//./_}-src.tgz)
+md5sums=('490ad9d920158e0314e10ba74ae9a150')
+
+build() {
+ cd ${srcdir}/${_pkgname}/source
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make -j5
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}/source
+ make -j5 DESTDIR=${pkgdir} install
+ rm -r "${pkgdir}"/usr/{bin,include,sbin,share,lib/*so,lib/icu/{Makefile.inc,current,pkgdata.inc}}
+ rm -r "${pkgdir}/usr/lib/pkgconfig"
+
+ # Install license
+ install -Dm644 ${srcdir}/${_pkgname}/license.html ${pkgdir}/usr/share/licenses/${pkgname}/license.html
+}