summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Turner2021-01-21 16:56:43 -0500
committerWilliam Turner2021-01-21 16:56:43 -0500
commitcd0127c0bd6cf38777c941398a2acb13858cacc7 (patch)
tree0f5326989b957c488f4f8f939885991af6fd3d31
downloadaur-cd0127c0bd6cf38777c941398a2acb13858cacc7.tar.gz
Initial version after PrestoSQL rebrand
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bccd26ca3fd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = trino-cli-bin
+ pkgdesc = Distributed SQL Query Engine for Big Data - Client
+ pkgver = 351
+ pkgrel = 1
+ url = https://trino.io/
+ arch = any
+ license = Apache
+ depends = java-runtime>=8
+ depends = sh
+ noextract = trino-cli-351-executable.jar
+ source = https://repo1.maven.org/maven2/io/trino/trino-cli/351/trino-cli-351-executable.jar
+ sha256sums = f525c91d2872a9bad7cc5bd83131eba30ef48c3e61378858c5a2d8471bc03605
+
+pkgname = trino-cli-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5b9509c74a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: William Turner <willtur.will@gmail.com>
+pkgname=trino-cli-bin
+pkgver=351
+pkgrel=1
+pkgdesc='Distributed SQL Query Engine for Big Data - Client'
+arch=('any')
+url='https://trino.io/'
+license=('Apache')
+depends=('java-runtime>=8' 'sh')
+source=("https://repo1.maven.org/maven2/io/trino/trino-cli/${pkgver}/trino-cli-${pkgver}-executable.jar")
+noextract=("trino-cli-${pkgver}-executable.jar")
+sha256sums=('f525c91d2872a9bad7cc5bd83131eba30ef48c3e61378858c5a2d8471bc03605')
+
+package() {
+ cd "${srcdir}"
+ install -D -m755 "trino-cli-${pkgver}-executable.jar" "${pkgdir}/usr/bin/trino"
+}