summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-08-30 19:29:29 +0200
committersballert2018-08-30 19:29:29 +0200
commitcd10a657f4e617bd4b3bf5c42c8c18d8d244eaa7 (patch)
tree92a854a6b558dd4a10717b28ad2b39f02e9942b7
downloadaur-cd10a657f4e617bd4b3bf5c42c8c18d8d244eaa7.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..355fe3b89a6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-hydra-git
+ pkgdesc = Make Emacs bindings that stick around
+ pkgver = r330.87cc74b
+ pkgrel = 1
+ url = https://github.com/abo-abo/hydra
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-hydra
+ conflicts = emacs-hydra
+ source = git+https://github.com/abo-abo/hydra.git
+ sha256sums = SKIP
+
+pkgname = emacs-hydra-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfd90c45ca2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+pkgname=emacs-hydra-git
+pkgver=r330.87cc74b
+pkgrel=1
+pkgdesc="Make Emacs bindings that stick around"
+url="https://github.com/abo-abo/hydra"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-hydra')
+conflicts=('emacs-hydra')
+source=("git+https://github.com/abo-abo/hydra.git")
+sha256sums=('SKIP')
+_gitname="hydra"
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitname"
+ make clean test compile
+}
+
+package() {
+ cd "$_gitname"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/hydra"
+ install -m644 {hydra-ox,hydra,lv}.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/hydra/"
+}