summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVersus Void2019-11-18 08:13:24 +0300
committerVersus Void2019-11-18 08:13:24 +0300
commitcd15ca9460a3b999d0017aa6c5f9fc9cb26b048e (patch)
tree99aadb3b2a8ea9a76bf90da0f664413bb5b16365
parent7ff2c40acc6b91a860ee183f9432574b61f1b3cf (diff)
downloadaur-cd15ca9460a3b999d0017aa6c5f9fc9cb26b048e.tar.gz
Fix double build, add sccache-dist, add conflicts
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50c6d84f3996..fb070b90bb29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sccache-git
pkgdesc = ccache-like tool. Wraps compiler and avoids compilation when possible. Supports rustc
- pkgver = r655.1087c20
+ pkgver = r801.9777708
pkgrel = 1
url = https://github.com/mozilla/sccache
install = sccache.install
@@ -9,6 +9,8 @@ pkgbase = sccache-git
license = Apache
makedepends = git
makedepends = rust
+ conflicts = sccache
+ conflicts = sccache-bin
source = git+https://github.com/mozilla/sccache/
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f6ccacb54b7b..c4666bfcea64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer: Versus Void <chaoskeeper@mail.ru>
+# Maintainer: Versus Void <chaoskeeper at mail DOT ru>
pkgname=sccache-git
-pkgver=r655.1087c20
+pkgver=r801.9777708
pkgrel=1
pkgdesc="ccache-like tool. Wraps compiler and avoids compilation when possible. Supports rustc"
arch=(i686 x86_64)
url="https://github.com/mozilla/sccache"
license=('Apache')
makedepends=('git' 'rust')
+conflicts=('sccache' 'sccache-bin')
install=sccache.install
source=('git+https://github.com/mozilla/sccache/')
sha256sums=('SKIP')
@@ -18,7 +19,7 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- cargo build --release
+ cargo build --release --all-features
}
#check() {
@@ -28,6 +29,7 @@ build() {
package() {
cd "$srcdir/${pkgname%-git}"
- cargo install --path . --root "$pkgdir/usr"
- rm -f "$pkgdir/usr/.crates.toml"
+ install -D target/release/sccache -t "$pkgdir"/usr/bin
+ install -D target/release/sccache-dist -t "$pkgdir"/usr/bin
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/sccache
}