summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMees Luten2020-09-01 17:18:00 +0200
committerMees Luten2020-09-01 17:18:00 +0200
commitcd22741fb6eece5b7b59da5fe808fabb1dec6c8f (patch)
tree47bc8e58ac98ef5bf303223b59a10ac3d782eb20
downloadaur-cd22741fb6eece5b7b59da5fe808fabb1dec6c8f.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02dd4f6e3968
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gr-hrpt
+ pkgdesc = HRPT Blocks from gr-noaa and others ported to GNU Radio 3.8+
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gitlab.altillimity.com/altillimity/gr-hrpt
+ arch = x86_64
+ license = GPL3
+ makedepends = boost
+ depends = gnuradio
+ depends = liborcus
+ source = https://gitlab.altillimity.com/altillimity/gr-hrpt/-/archive/master/gr-hrpt-master.tar.gz
+ sha256sums = c1e730d3717c73037b8ceee3fce10320cc06d0da8225a16591caa543bd9abf6f
+
+pkgname = gr-hrpt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de0f4a0f1023
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Mees Luten <mees.luten@gmail.com>
+pkgname=gr-hrpt
+pkgver=0.1
+pkgrel=1
+epoch=
+pkgdesc="HRPT Blocks from gr-noaa and others ported to GNU Radio 3.8+"
+arch=(x86_64)
+url="https://gitlab.altillimity.com/altillimity/gr-hrpt"
+license=('GPL3')
+groups=()
+depends=(gnuradio liborcus)
+makedepends=(boost)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://gitlab.altillimity.com/altillimity/gr-hrpt/-/archive/master/gr-hrpt-master.tar.gz")
+noextract=()
+sha256sums=('c1e730d3717c73037b8ceee3fce10320cc06d0da8225a16591caa543bd9abf6f')
+validpgpkeys=()
+
+prepare() {
+ rm -f -r $pkgname
+ mv gr-hrpt-master $pkgname
+ mkdir -p "$pkgname"/build
+}
+
+
+build() {
+ cd "$pkgname"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make -j 2
+}
+
+package() {
+ cd "$pkgname"/build
+ make DESTDIR="$pkgdir/" install
+}