summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-09 18:19:52 -0600
committerBrian Bidulock2015-07-09 18:19:52 -0600
commitcd58e5bf432483e6c37c48279ec36cb2a916ba29 (patch)
treee859d64609e881c7569e953a274fc393c134601a
downloadaur-cd58e5bf432483e6c37c48279ec36cb2a916ba29.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0866eb17347
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gtk-engine-equinox
+ pkgdesc = A heavily modified version of the beautiful Aurora engine
+ pkgver = 1.50
+ pkgrel = 2
+ url = http://gnome-look.org/content/show.php/Equinox+GTK+Engine?content=121881
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libtool
+ depends = gtk2
+ options = !libtool
+ source = http://gnome-look.org/CONTENT/content-files/121881-equinox-1.50.tar.gz
+ sha256sums = 0cf8b8cc841e0da7d4a08ab5a70d3bb330fd76bdcb03165a47aaddcd47e02227
+
+pkgname = gtk-engine-equinox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8127beb34cd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer : SpepS <dreamspepser at yahoo dot it>
+# Contributor: Frikilinux <frikilinux at frikilinux.com.ar>
+
+pkgname=gtk-engine-equinox
+pkgver=1.50
+pkgrel=2
+pkgdesc="A heavily modified version of the beautiful Aurora engine"
+url="http://gnome-look.org/content/show.php/Equinox+GTK+Engine?content=121881"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('gtk2')
+makedepends=('libtool')
+options=('!libtool')
+source=("http://gnome-look.org/CONTENT/content-files/121881-equinox-$pkgver.tar.gz")
+sha256sums=('0cf8b8cc841e0da7d4a08ab5a70d3bb330fd76bdcb03165a47aaddcd47e02227')
+
+build() {
+ cd "$srcdir/equinox-$pkgver"
+
+ # toolbar fix
+ sed -i "s/=\( EQUINOX_IS_TOOLBAR\)/= widget \&\&\1/" \
+ src/equinox_style.c
+
+ # glib2 fix
+ sed -i "/gtimer/d" src/animation.c
+
+ ./configure --prefix=/usr \
+ --enable-animation
+ make
+}
+package() {
+ cd "$srcdir/equinox-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}