summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvert Vorster2023-05-12 22:09:29 +0200
committerEvert Vorster2023-05-12 22:09:29 +0200
commitcd86ce495d48b23facf142f1330a63d9cd80df67 (patch)
tree5dfb19d40f75e9b8229cbcbb0f25dfe9ac47bd89
parent19903b2ea776ce4196d06064a42454d6cde066c6 (diff)
downloadaur-cd86ce495d48b23facf142f1330a63d9cd80df67.tar.gz
Version update, and messing with the build system
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95a3c949f1f0..4cb2f528a0ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = audacity-qt-git
pkgdesc = Record and edit audio files-tracking the QT branch in git
- pkgver = 3.3.0.0.r16557
+ pkgver = 3.3.0.0.r16783
pkgrel = 1
url = https://audacityteam.org
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = audacity-qt-git
makedepends = automake
makedepends = libtool
makedepends = git
- makedepends = conan
+ makedepends = conan1
makedepends = catch2
depends = libmad
depends = libid3tag
diff --git a/PKGBUILD b/PKGBUILD
index ff817a668f14..a739fe955f72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: osch <oliver@luced.de>
pkgname=audacity-qt-git
-pkgver=3.3.0.0.r16557
+pkgver=3.3.0.0.r16783
pkgrel=1
pkgdesc="Record and edit audio files-tracking the QT branch in git"
arch=('x86_64')
@@ -13,7 +13,7 @@ depends=('libmad' 'libid3tag' 'gtk2' 'glib2' 'soundtouch' 'ffmpeg' 'vamp-plugin-
'portsmf' 'portmidi' 'twolame' 'suil' 'lilv' 'lv2' 'serd' 'sord' 'sratom' 'python'
'flac' 'libvorbis' 'libogg' 'vamp-plugin-sdk' 'portaudio' 'libsoxr' 'libsndfile' 'lame'
'expat' 'alsa-lib' 'jack' 'util-linux' 'util-linux-libs' 'curl' 'zlib')
-makedepends=('cmake' 'autoconf' 'automake' 'libtool' 'git' 'conan' 'catch2')
+makedepends=('cmake' 'autoconf' 'automake' 'libtool' 'git' 'conan1' 'catch2')
provides=("audacity")
conflicts=("audacity")
source=(
@@ -32,21 +32,26 @@ pkgver() {
}
prepare() {
-# cd "audacity-Audacity-${pkgver}"
-# sed -i -e '/#include <iterator>/i #include <limits>' libraries/lib-utility/MemoryX.h
+ export CC=gcc
+ export VST3_SDK_DIR='/usr/src/vst3sdk'
+
mkdir -p build
cd build
+
depsDir=$(readlink -f ./.offline)
export CONAN_USER_HOME="$depsDir/conan"
conan config home
conan config init
conan config set storage.download_cache="$CONAN_USER_HOME/download_cache"
- conan remove "*" --src --builds --force
+#Let's not remove it every time, it's a pain building them.
+# conan remove "*" --src --builds --force
+
cmake -G "Unix Makefiles" ../audacity \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-Daudacity_use_ffmpeg=loaded \
- -Daudacity_has_vst3=Off
+ -Daudacity_use_vst3sdk=system
+# -Daudacity_has_vst3=Off \
# -DAUDACITY_BUILD_LEVEL=2 \
# -Daudacity_has_networking=off \
# -Daudacity_lib_preference=system local \
@@ -59,18 +64,13 @@ prepare() {
}
build() {
-#pwd
cd build
-# cd "audacity-Audacity-${pkgver}"/build
make
- conan remove "*" --src --builds --force
+#Let's not remove the conan stuff every time, rebuilding's a pain.
+# conan remove "*" --src --builds --force
}
package() {
make -C build DESTDIR="${pkgdir}" install
-# cd "audacity-Audacity-${pkgver}"/build
-# make DESTDIR="${pkgdir}" install
-# rm "${pkgdir}"/usr/audacity
-# chmod -R go=u "${pkgdir}"
-# chmod -R go-w "${pkgdir}"
}
+