summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNocifer2022-07-03 10:04:20 +0300
committerNocifer2022-07-03 10:04:20 +0300
commitcdbef2c607de0b2770ee2b9de509f61b5a04051a (patch)
tree27c0a4628b81722e1c835e2630128bf95acf439f
parent28d3d450ab49afc0ee38c0e5682aa4edef130f46 (diff)
downloadaur-cdbef2c607de0b2770ee2b9de509f61b5a04051a.tar.gz
v=2.28.4770.102,r=1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--fcitx.patch96
3 files changed, 58 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b79a69fcaba9..27b1d3e393e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fcitx-mozc-ut
pkgdesc = Mozc module for Fcitx
- pkgver = 2.28.4740.102
+ pkgver = 2.28.4770.102
pkgrel = 1
url = https://github.com/fcitx/mozc
arch = x86_64
@@ -13,15 +13,15 @@ pkgbase = fcitx-mozc-ut
makedepends = python
makedepends = qt5-base
depends = fcitx
- depends = mozc>=2.28.4740.102
+ depends = mozc>=2.28.4770.102
optdepends = fcitx-configtool
- provides = fcitx-mozc=2.28.4740.102
+ provides = fcitx-mozc=2.28.4770.102
conflicts = fcitx-mozc
options = !distcc
options = !ccache
- source = fcitx-mozc-ut-git::git+https://github.com/google/mozc.git#commit=73f289987769fe1dd381bf436b5888a2a663e276
+ source = fcitx-mozc-ut-git::git+https://github.com/google/mozc.git#commit=5e3542b98adb743553e672f34caee6d5d8021b85
source = fcitx.patch
sha256sums = SKIP
- sha256sums = 1607109bc0d98382dfa30ba4fe5909a4a7758e7c7cb95df97223202b5b8c3dbc
+ sha256sums = 02411077f078631811a90a7366d1da2f58d4a0440771c015dd40e5910c2cf4a2
pkgname = fcitx-mozc-ut
diff --git a/PKGBUILD b/PKGBUILD
index 761b2849c82e..adbabf500314 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,22 @@
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
pkgname='fcitx-mozc-ut'
-pkgver=2.28.4740.102
+pkgver=2.28.4770.102
pkgrel=1
pkgdesc='Mozc module for Fcitx'
arch=('x86_64')
url='https://github.com/fcitx/mozc'
license=('Apache' 'BSD' 'LGPL' 'custom')
-depends=('fcitx' 'mozc>=2.28.4740.102')
+depends=('fcitx' 'mozc>=2.28.4770.102')
makedepends=('bazel' 'git' 'python' 'qt5-base')
optdepends=('fcitx-configtool')
-provides=('fcitx-mozc=2.28.4740.102')
+provides=('fcitx-mozc=2.28.4770.102')
conflicts=('fcitx-mozc')
options=(!distcc !ccache)
-source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=73f289987769fe1dd381bf436b5888a2a663e276"
+source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=5e3542b98adb743553e672f34caee6d5d8021b85"
"fcitx.patch")
sha256sums=('SKIP'
- '1607109bc0d98382dfa30ba4fe5909a4a7758e7c7cb95df97223202b5b8c3dbc')
+ '02411077f078631811a90a7366d1da2f58d4a0440771c015dd40e5910c2cf4a2')
prepare() {
cd ${pkgname}-git/src
diff --git a/fcitx.patch b/fcitx.patch
index 3a8687e2f121..c054e706454a 100644
--- a/fcitx.patch
+++ b/fcitx.patch
@@ -1,6 +1,6 @@
diff -ruN google-mozc-git/src/BUILD.fcitx.bazel fcitx-mozc-git/src/BUILD.fcitx.bazel
--- google-mozc-git/src/BUILD.fcitx.bazel 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/BUILD.fcitx.bazel 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/BUILD.fcitx.bazel 2022-07-03 09:58:03.694456181 +0300
@@ -0,0 +1,27 @@
+package(
+ default_visibility = ["//visibility:public"],
@@ -31,7 +31,7 @@ diff -ruN google-mozc-git/src/BUILD.fcitx.bazel fcitx-mozc-git/src/BUILD.fcitx.b
+)
diff -ruN google-mozc-git/src/unix/fcitx/BUILD fcitx-mozc-git/src/unix/fcitx/BUILD
--- google-mozc-git/src/unix/fcitx/BUILD 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/BUILD 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/BUILD 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,97 @@
+load(
+ "//:build_defs.bzl",
@@ -132,7 +132,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/BUILD fcitx-mozc-git/src/unix/fcitx/BUI
+
diff -ruN google-mozc-git/src/unix/fcitx/eim.cc fcitx-mozc-git/src/unix/fcitx/eim.cc
--- google-mozc-git/src/unix/fcitx/eim.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/eim.cc 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/eim.cc 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,271 @@
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
+// All rights reserved.
@@ -407,7 +407,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/eim.cc fcitx-mozc-git/src/unix/fcitx/ei
+}
diff -ruN google-mozc-git/src/unix/fcitx/fcitx.gyp fcitx-mozc-git/src/unix/fcitx/fcitx.gyp
--- google-mozc-git/src/unix/fcitx/fcitx.gyp 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx.gyp 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx.gyp 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,111 @@
+#
+# Copyright (c) 2010-2012 fcitx Project http://code.google.com/p/fcitx/
@@ -522,7 +522,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx.gyp fcitx-mozc-git/src/unix/fcitx
+}
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc
--- google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,243 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -769,7 +769,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc fcitx-mozc-g
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h
--- google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,79 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -852,7 +852,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h fcitx-mozc-gi
+#endif // MOZC_UNIX_FCITX_KEY_EVENT_HANDLER_H_
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_translator.cc fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.cc
--- google-mozc-git/src/unix/fcitx/fcitx_key_translator.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.cc 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.cc 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,521 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -1377,7 +1377,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_translator.cc fcitx-mozc-git/
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_translator.h fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.h
--- google-mozc-git/src/unix/fcitx/fcitx_key_translator.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.h 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.h 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,121 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -1502,7 +1502,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_translator.h fcitx-mozc-git/s
+#endif // MOZC_UNIX_FCITX_FCITX_KEY_TRANSLATOR_H_
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_mozc.cc fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.cc
--- google-mozc-git/src/unix/fcitx/fcitx_mozc.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.cc 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.cc 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,552 @@
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
+// All rights reserved.
@@ -2058,7 +2058,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_mozc.cc fcitx-mozc-git/src/unix/f
+} // namespace mozc_unix_scim
diff -ruN google-mozc-git/src/unix/fcitx/fcitx-mozc.conf fcitx-mozc-git/src/unix/fcitx/fcitx-mozc.conf
--- google-mozc-git/src/unix/fcitx/fcitx-mozc.conf 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx-mozc.conf 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx-mozc.conf 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,11 @@
+[Addon]
+Name=fcitx-mozc
@@ -2073,7 +2073,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx-mozc.conf fcitx-mozc-git/src/unix
+LoadLocal=True
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_mozc.h fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.h
--- google-mozc-git/src/unix/fcitx/fcitx_mozc.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.h 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.h 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,176 @@
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
+// All rights reserved.
@@ -2253,7 +2253,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_mozc.h fcitx-mozc-git/src/unix/fc
+
diff -ruN google-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh fcitx-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh
--- google-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,10 @@
+#!/bin/sh
+
@@ -2267,7 +2267,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh fcitx-mozc-git/s
+done
diff -ruN google-mozc-git/src/unix/fcitx/mozc.conf fcitx-mozc-git/src/unix/fcitx/mozc.conf
--- google-mozc-git/src/unix/fcitx/mozc.conf 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc.conf 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/mozc.conf 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,7 @@
+[InputMethod]
+UniqueName=mozc
@@ -2278,7 +2278,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc.conf fcitx-mozc-git/src/unix/fcitx
+Parent=fcitx-mozc
diff -ruN google-mozc-git/src/unix/fcitx/mozc_connection.cc fcitx-mozc-git/src/unix/fcitx/mozc_connection.cc
--- google-mozc-git/src/unix/fcitx/mozc_connection.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc_connection.cc 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/mozc_connection.cc 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,214 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -2496,7 +2496,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc_connection.cc fcitx-mozc-git/src/u
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/mozc_connection.h fcitx-mozc-git/src/unix/fcitx/mozc_connection.h
--- google-mozc-git/src/unix/fcitx/mozc_connection.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc_connection.h 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/mozc_connection.h 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,154 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -2654,7 +2654,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc_connection.h fcitx-mozc-git/src/un
+#endif // MOZC_UNIX_SCIM_MOZC_CONNECTION_H_
diff -ruN google-mozc-git/src/unix/fcitx/mozc_response_parser.cc fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.cc
--- google-mozc-git/src/unix/fcitx/mozc_response_parser.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.cc 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.cc 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,447 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -3105,7 +3105,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc_response_parser.cc fcitx-mozc-git/
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/mozc_response_parser.h fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.h
--- google-mozc-git/src/unix/fcitx/mozc_response_parser.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.h 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.h 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,97 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -3206,7 +3206,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc_response_parser.h fcitx-mozc-git/s
+#endif // MOZC_UNIX_FCITX_MOZC_RESPONSE_PARSER_H_
diff -ruN google-mozc-git/src/unix/fcitx/po/ca.po fcitx-mozc-git/src/unix/fcitx/po/ca.po
--- google-mozc-git/src/unix/fcitx/po/ca.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/ca.po 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/ca.po 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,80 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3290,7 +3290,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ca.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Premeu Ctrl+Alt+H per mostrar els usos."
diff -ruN google-mozc-git/src/unix/fcitx/po/da.po fcitx-mozc-git/src/unix/fcitx/po/da.po
--- google-mozc-git/src/unix/fcitx/po/da.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/da.po 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/da.po 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,80 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3374,7 +3374,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/da.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Tryk på Ctrl+Alt+H for at vise anvendelser."
diff -ruN google-mozc-git/src/unix/fcitx/po/de.po fcitx-mozc-git/src/unix/fcitx/po/de.po
--- google-mozc-git/src/unix/fcitx/po/de.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/de.po 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/de.po 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,86 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3464,7 +3464,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/de.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Ctrl+Alt+H um die Hilfe anzuzeigen"
diff -ruN google-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot fcitx-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot
--- google-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,78 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3546,7 +3546,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot fcitx-mozc-git/src/un
+msgstr ""
diff -ruN google-mozc-git/src/unix/fcitx/po/ja.po fcitx-mozc-git/src/unix/fcitx/po/ja.po
--- google-mozc-git/src/unix/fcitx/po/ja.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/ja.po 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/ja.po 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,87 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3637,7 +3637,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ja.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Ctrl+Alt+H キーを押して用例を表示"
diff -ruN google-mozc-git/src/unix/fcitx/po/ko.po fcitx-mozc-git/src/unix/fcitx/po/ko.po
--- google-mozc-git/src/unix/fcitx/po/ko.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/ko.po 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/ko.po 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,82 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3723,7 +3723,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ko.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "사용법을 보려면 Ctrl+Alt+H를 누릅니다."
diff -ruN google-mozc-git/src/unix/fcitx/po/Messages.sh fcitx-mozc-git/src/unix/fcitx/po/Messages.sh
--- google-mozc-git/src/unix/fcitx/po/Messages.sh 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/Messages.sh 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/Messages.sh 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,33 @@
+#!/bin/sh
+
@@ -3760,7 +3760,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/Messages.sh fcitx-mozc-git/src/unix/
+echo "Done"
diff -ruN google-mozc-git/src/unix/fcitx/po/ru.po fcitx-mozc-git/src/unix/fcitx/po/ru.po
--- google-mozc-git/src/unix/fcitx/po/ru.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/ru.po 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/ru.po 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,82 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3773,71 +3773,71 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ru.po fcitx-mozc-git/src/unix/fcitx/
+msgstr ""
+"Project-Id-Version: fcitx\n"
+"Report-Msgid-Bugs-To: fcitx-dev@googlegroups.com\n"
-+"POT-Creation-Date: 2020-11-11 00:03-0800\n"
-+"PO-Revision-Date: 2020-11-10 08:03+0000\n"
-+"Last-Translator: csslayer <wengxt@gmail.com>\n"
++"POT-Creation-Date: 2022-06-02 20:29+0000\n"
++"PO-Revision-Date: 2012-03-06 06:51+0000\n"
++"Last-Translator: TotalCaesar659 <x24cm5b8c54q6szxw@yandex.ru>, 2016\n"
+"Language-Team: Russian (http://www.transifex.com/fcitx/fcitx/language/ru/)\n"
+"Language: ru\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
-+"Plural-Forms: nplurals=4; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && n"
-+"%10<=4 && (n%100<12 || n%100>14) ? 1 : n%10==0 || (n%10>=5 && n%10<=9) || (n"
-+"%100>=11 && n%100<=14)? 2 : 3);\n"
++"Plural-Forms: nplurals=4; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && "
++"n%10<=4 && (n%100<12 || n%100>14) ? 1 : n%10==0 || (n%10>=5 && n%10<=9) || "
++"(n%100>=11 && n%100<=14)? 2 : 3);\n"
+
+#: ../eim.cc:187
+msgid "Press Escape to go back"
+msgstr "Нажмите для перехода назад"
+
-+#: ../fcitx_mozc.cc:65
++#: ../fcitx_mozc.cc:68
+msgid "Direct"
+msgstr "Прямой"
+
-+#: ../fcitx_mozc.cc:70
++#: ../fcitx_mozc.cc:73
+msgid "Hiragana"
+msgstr "Хирагана"
+
-+#: ../fcitx_mozc.cc:75
++#: ../fcitx_mozc.cc:78
+msgid "Full Katakana"
+msgstr "Полная катакана"
+
-+#: ../fcitx_mozc.cc:80
++#: ../fcitx_mozc.cc:83
+msgid "Half ASCII"
+msgstr "Половинный "
+
-+#: ../fcitx_mozc.cc:85
++#: ../fcitx_mozc.cc:88
+msgid "Full ASCII"
+msgstr "Полный "
+
-+#: ../fcitx_mozc.cc:90
++#: ../fcitx_mozc.cc:93
+msgid "Half Katakana"
+msgstr "Половинная катакана"
+
-+#: ../fcitx_mozc.cc:406 ../fcitx_mozc.cc:407 ../fcitx_mozc.cc:469
++#: ../fcitx_mozc.cc:409 ../fcitx_mozc.cc:410 ../fcitx_mozc.cc:472
+msgid "Composition Mode"
+msgstr "Режим композиции"
+
-+#: ../fcitx_mozc.cc:417 ../fcitx_mozc.cc:418
++#: ../fcitx_mozc.cc:420 ../fcitx_mozc.cc:421
+msgid "Tool"
+msgstr "Инструмент"
+
-+#: ../fcitx_mozc.cc:482
++#: ../fcitx_mozc.cc:485
+msgid "Mozc Tool"
+msgstr "Инструмент Mozc"
+
-+#: ../fcitx_mozc.cc:488
++#: ../fcitx_mozc.cc:491
+msgid "Configuration Tool"
+msgstr "Инструмент настройки"
+
-+#: ../fcitx_mozc.cc:489
++#: ../fcitx_mozc.cc:492
+msgid "Dictionary Tool"
+msgstr "Инструмент словаря"
+
-+#: ../fcitx_mozc.cc:490
++#: ../fcitx_mozc.cc:493
+msgid "Add Word"
+msgstr "Добавить слово"
+
-+#: ../fcitx_mozc.cc:491
++#: ../fcitx_mozc.cc:494
+msgid "About Mozc"
+msgstr "О "
+
@@ -3846,7 +3846,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ru.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Нажмите Ctrl+Alt+H, чтобы показать использование."
diff -ruN google-mozc-git/src/unix/fcitx/po/zh_CN.po fcitx-mozc-git/src/unix/fcitx/po/zh_CN.po
--- google-mozc-git/src/unix/fcitx/po/zh_CN.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/zh_CN.po 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/zh_CN.po 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,85 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3935,7 +3935,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/zh_CN.po fcitx-mozc-git/src/unix/fci
+msgstr "按下 Ctrl+Alt+H 显示用法。"
diff -ruN google-mozc-git/src/unix/fcitx/po/zh_TW.po fcitx-mozc-git/src/unix/fcitx/po/zh_TW.po
--- google-mozc-git/src/unix/fcitx/po/zh_TW.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/zh_TW.po 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/zh_TW.po 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,84 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -4023,7 +4023,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/zh_TW.po fcitx-mozc-git/src/unix/fci
+msgstr "按下 Ctrl+Alt+H 顯示用法。"
diff -ruN google-mozc-git/src/unix/fcitx/surrounding_text_util.cc fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.cc
--- google-mozc-git/src/unix/fcitx/surrounding_text_util.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.cc 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.cc 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,243 @@
+// Copyright 2010-2013, Google Inc.
+// All rights reserved.
@@ -4270,7 +4270,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/surrounding_text_util.cc fcitx-mozc-git
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/surrounding_text_util.h fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.h
--- google-mozc-git/src/unix/fcitx/surrounding_text_util.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.h 2022-05-30 00:29:46.151683315 +0300
++++ fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.h 2022-07-03 09:58:03.697790230 +0300
@@ -0,0 +1,87 @@
+// Copyright 2010-2013, Google Inc.
+// All rights reserved.