summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2018-04-03 12:58:55 -0400
committerGI_Jack2018-04-03 12:58:55 -0400
commitcded57da799a5b45735250270f2a354a9f68d3f8 (patch)
treeeae3d791b0e8a00e8f915ae31749a491052d9f47
downloadaur-cded57da799a5b45735250270f2a354a9f68d3f8.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10b0895c0c10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Apr 3 16:58:45 UTC 2018
+pkgbase = enum4linux
+ pkgdesc = A tool for enumerating information from Windows and Samba systems.
+ pkgver = 0.8.9
+ pkgrel = 1
+ url = http://labs.portcullis.co.uk/application/enum4linux/
+ arch = any
+ license = GPL
+ depends = perl
+ depends = smbclient
+ depends = polenum
+ depends = openldap
+ source = http://labs.portcullis.co.uk/download/enum4linux-0.8.9.tar.gz
+ sha512sums = 3c3973ed85cbd585f5534a6871c4c07111d112d0be4e776780974e06ad4f0e47132a7d22e6c68658af5903811e9b87ef77e0b48e3dad848e2ebef5058b46ac83
+
+pkgname = enum4linux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4176899678e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+# Poached from Arch Strike
+# Original: ArchStrike <team@archstrike.org>
+
+pkgname=enum4linux
+pkgver=0.8.9
+pkgrel=1
+pkgdesc="A tool for enumerating information from Windows and Samba systems."
+arch=('any')
+url="http://labs.portcullis.co.uk/application/enum4linux/"
+license=('GPL')
+depends=('perl' 'smbclient' 'polenum' 'openldap')
+source=(http://labs.portcullis.co.uk/download/enum4linux-$pkgver.tar.gz)
+sha512sums=('3c3973ed85cbd585f5534a6871c4c07111d112d0be4e776780974e06ad4f0e47132a7d22e6c68658af5903811e9b87ef77e0b48e3dad848e2ebef5058b46ac83')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ sed -i 's|polenum.py|polenum|' ${pkgname}.pl
+}
+
+package() {
+ cd "$srcdir/enum4linux-$pkgver"
+
+ install -Dm755 enum4linux.pl "$pkgdir/usr/bin/enum4linux"
+ install -Dm644 share-list.txt "$pkgdir/usr/share/enum4linux/share-list.txt"
+}