summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrhysd2023-07-11 22:23:15 +0900
committerrhysd2023-07-12 10:52:08 +0900
commitce03a4d37dc5c454ecf919052f5b95842e4e820b (patch)
tree93e3d4b02cc1d1053e68e48320be6fd8b14037bc
parent8c2e6531c442208b63dd8a35e48c1b9f9079b611 (diff)
downloadaur-ce03a4d37dc5c454ecf919052f5b95842e4e820b.tar.gz
set actionlint version by ldflags on building executable
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b8256d488d2..195208b0644d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=actionlint
pkgver=1.6.25
-pkgrel=1
+pkgrel=2
pkgdesc="Static checker for GitHub Actions workflow files"
arch=('any')
url="https://github.com/rhysd/actionlint"
@@ -24,7 +24,7 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build -o build ./cmd/${pkgname}
+ go build -ldflags "-X github.com/rhysd/actionlint.version=$pkgver" -o build ./cmd/${pkgname}
}
check() {