summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHsiu-Ming Chang2018-09-07 21:47:18 +0800
committerHsiu-Ming Chang2018-09-07 21:52:13 +0800
commitce073509cbb7ee48fe42a7f718374f117cbe792c (patch)
tree3d00f9cb0527ea2ba2e08ff093f7334a8c9e8f5c
downloadaur-ce073509cbb7ee48fe42a7f718374f117cbe792c.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD37
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d94f0a3f43a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pdfhandoutcrop
+ pkgdesc = A tool to crop pdf handout with multiple pages per sheet
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://cges30901.github.io/pdfhandoutcrop/
+ arch = any
+ license = GPL3
+ depends = python-pypdf2
+ depends = python-pyqt5
+ depends = python-poppler-qt5
+ source = https://files.pythonhosted.org/packages/source/p/pdfhandoutcrop/pdfhandoutcrop-0.3.1.tar.gz
+ md5sums = 8a557c0004aa50a630b5d037b7d8529f
+
+pkgname = pdfhandoutcrop
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ecbe6a73acf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Hsiu-Ming Chang <cges30901 at gmail dot com>
+
+pkgname=pdfhandoutcrop
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="A tool to crop pdf handout with multiple pages per sheet"
+arch=(any)
+url="https://cges30901.github.io/pdfhandoutcrop/"
+license=('GPL3')
+groups=()
+depends=('python-pypdf2' 'python-pyqt5' 'python-poppler-qt5')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+#install="$pkgname.install"
+changelog=
+source=("https://files.pythonhosted.org/packages/source/p/pdfhandoutcrop/pdfhandoutcrop-${pkgver}.tar.gz")
+noextract=()
+md5sums=('8a557c0004aa50a630b5d037b7d8529f')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ python setup.py install --prefix=/usr --root="$pkgdir"
+ install -D -m0644 pdfhandoutcrop.desktop $pkgdir/usr/share/applications/pdfhandoutcrop.desktop
+ install -D -m0644 icons/128/pdfhandoutcrop.png $pkgdir/usr/share/icons/hicolor/128x128/apps/pdfhandoutcrop.png
+ install -D -m0644 icons/48/pdfhandoutcrop.png $pkgdir/usr/share/icons/hicolor/48x48/apps/pdfhandoutcrop.png
+}