summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulioJu2016-05-29 17:52:02 +0200
committerJulioJu2016-05-29 17:52:02 +0200
commitce1df8a29bd5990a4722a5469bea9624ac711690 (patch)
tree328163f576a8c45c5082e076996ffbe9d04a9391
parentb1e520adc6b1728ef5aa3bf7ab33eb9666fefdbf (diff)
downloadaur-ce1df8a29bd5990a4722a5469bea9624ac711690.tar.gz
correct error in command line curl
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31fec9c3a290..8a0a6c477cae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -75,8 +75,8 @@ build () {
if type uname 1>&2 && [[ $(uname -m) = "${CARCH}" ]]; then
local BUGFIX_FILE="bugfix-5237.diff"
echo "Downloading the ocaml 3.11 patch ($BUGFIX_FILE) for ${CARCH}"
- curl -o $BUGFIX_FILE "$OUR_MIRROR/$BUGFIX_FILE" || \
- curl -o $BUGFIX_FILE 'http://caml.inria.fr/mantis/file_download.php?file_id=415&type=bug' || \
+ curl -L -o $BUGFIX_FILE "$OUR_MIRROR/$BUGFIX_FILE" || \
+ curl -L -o $BUGFIX_FILE 'http://caml.inria.fr/mantis/file_download.php?file_id=415&type=bug' || \
return 1
echo "Applying the ocaml 3.11 patch ($BUGFIX_FILE) for ${CARCH}"
patch -p1 < $BUGFIX_FILE
@@ -85,8 +85,8 @@ build () {
elif type ld 1>&2 && ld -v | \grep -q '[ ]2[.]2[1-9]'; then
local BUGFIX_FILE="bugfix-5237-i386.diff"
echo "Downloading the ocaml 3.11 patch ($BUGFIX_FILE) for i386"
- curl -o $BUGFIX_FILE "$OUR_MIRROR/$BUGFIX_FILE" || \
- curl -o $BUGFIX_FILE 'http://caml.inria.fr/mantis/file_download.php?file_id=418&type=bug' || \
+ curl -L -o $BUGFIX_FILE "$OUR_MIRROR/$BUGFIX_FILE" || \
+ curl -L -o $BUGFIX_FILE 'http://caml.inria.fr/mantis/file_download.php?file_id=418&type=bug' || \
return 1
echo "Applying the ocaml 3.11 patch ($BUGFIX_FILE) for i386"
patch -p1 < $BUGFIX_FILE