summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-06-27 18:07:30 -0500
committerCarlos Aznarán Laos2022-06-27 18:07:30 -0500
commitce74a4b5ccb35e4e83e28f080965322a9992dff1 (patch)
treeb7cdd32f7373a2ced61acdad858d8b48abbca9bb
parentb6f60718b40270e89fed5896a3445931ca4f265b (diff)
downloadaur-ce74a4b5ccb35e4e83e28f080965322a9992dff1.tar.gz
Replace python2 by python
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD110
2 files changed, 58 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eedd5d794b54..294b98b00087 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,29 @@
pkgbase = trilinos-git
- pkgdesc = Algorithms for the solution of large-scale, complex multi-physics engineering and scientific problems.
- pkgver = 12.12.11145.g7a152b4248
+ pkgdesc = Algorithms for the solution of large-scale, complex multi-physics engineering and scientific problems
+ pkgver = 12.12.21207.g90d80e9f993
pkgrel = 1
url = https://github.com/trilinos/Trilinos
arch = x86_64
license = LGPL3
- makedepends = git
- makedepends = python2
- makedepends = python2-numpy
- makedepends = swig
- makedepends = gcc
makedepends = gcc-fortran
- makedepends = openmpi
makedepends = perl
makedepends = blas
- makedepends = lapack
makedepends = cmake
- makedepends = libmatio
- makedepends = netcdf
- makedepends = ccache
+ makedepends = git
+ makedepends = python-numpy
+ makedepends = swig
+ makedepends = doxygen
+ makedepends = graphviz
+ depends = python
depends = lapack
- depends = openmpi
- depends = python2
depends = boost
- provides = trilinos
- conflicts = trilinos
- options = ccache
- source = git+https://github.com/trilinos/Trilinos.git
+ depends = netcdf-openmpi
+ depends = libmatio
+ depends = libx11
+ depends = hdf5-openmpi
+ provides = trilinos-git
+ conflicts = trilinos-git
+ source = Trilinos::git+https://github.com/trilinos/Trilinos.git
md5sums = SKIP
pkgname = trilinos-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 865d61fff242..4f4ea5a91a30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,83 +1,59 @@
-# Maintainer: Myles English <myles at rockhead.biz>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Myles English <myles at rockhead.biz>
# Contributor: Feng Wang <wanng.fenng@gmail.com>
# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
-######################################################################
-# CAVEAT LECTOR
-######################################################################
-#
-# Make sure you have enough RAM to build this package.
-# It consumes about 6GB RAM for me when building, even if I
-# keep the src dir on the disk instead of a tmpfs!
-#
-# Keeping the srcdir and using ccache option for faster compilation
-# the next time would be a good choice.
-#
-# "makepkg -i" is your friend.
-#
-######################################################################
-
-pkgname=trilinos-git
_pkgname=Trilinos
-pkgver=12.12.11145.g7a152b4248
+pkgname=${_pkgname,,}-git
+pkgver=12.12.21207.g90d80e9f993
pkgrel=1
-pkgdesc="Algorithms for the solution of large-scale, complex multi-physics engineering and scientific problems."
-arch=('x86_64')
-url="https://github.com/trilinos/Trilinos"
-license=('LGPL3')
-depends=('lapack' 'openmpi' 'python2' 'boost')
-provides=('trilinos')
-conflicts=('trilinos')
-source=(git+${url}.git)
-makedepends=('git' 'python2' 'python2-numpy' 'swig' 'gcc' 'gcc-fortran' 'openmpi' 'perl' 'blas' 'lapack' 'cmake' 'libmatio' 'netcdf' 'ccache')
-# gcc-fortran gcc-fortran-multilib
+pkgdesc="Algorithms for the solution of large-scale, complex multi-physics engineering and scientific problems"
+arch=(x86_64)
+url="https://github.com/${_pkgname,,}/${_pkgname}"
+license=(LGPL3)
+source=(${_pkgname}::git+${url}.git)
+depends=(python lapack boost netcdf-openmpi libmatio libx11 hdf5-openmpi)
+makedepends=(gcc-fortran perl blas cmake git python-numpy swig doxygen graphviz) # gcc-fortran-multilib
md5sums=('SKIP')
-options=('ccache')
+provides=("${pkgname,,}")
+conflicts=("${pkgname,,}")
pkgver() {
- cd "${srcdir}/${_pkgname}"
- #printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${_pkgname}
+ # printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
git describe --long | sed -e 's/root-of-trilinos-release-//' -e 's/branch-//' -e 's/^v//;s/-/./g'
}
build() {
- cd "$srcdir/${_pkgname}"
-
- find ${srcdir}/${_pkgname} -name "*" -type f -exec \
- sed -i 's#\(/usr/bin/env \|/usr/bin/\)python[2-3]*#\1python2#' {} \;
-
- [[ -e build ]] && rm -rf build
- mkdir build
- cd build
-
- cmake .. \
- -DTrilinos_ENABLE_ALL_PACKAGES:BOOL=ON \
- -DTrilinos_ENABLE_FEI=OFF \
- -DTrilinos_ENABLE_STKClassic=OFF \
- -DTrilinos_ENABLE_SEACAS=ON \
- -DTrilinos_ENABLE_Sundance=OFF \
- -DTrilinos_ENABLE_TESTS=OFF \
- -DTrilinos_ENABLE_OpenMP:BOOL=ON \
- -DTPL_ENABLE_MPI:BOOL=ON \
- -DTrilinos_ENABLE_PyTrilinos:BOOL=ON \
- -DPyTrilinos_DOCSTRINGS:BOOL=OFF \
- -DPYTHON_EXECUTABLE:PATH=/usr/bin/python2 \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DTPL_ENABLE_Netcdf=ON \
- -DTPL_ENABLE_QT=OFF \
- -DTPL_ENABLE_GLM=OFF \
- -DBUILD_SHARED_LIBS:BOOL=ON \
- $EXTRA_ARGS
-
- make
-}
-
-check() {
- cd $srcdir/${_pkgname}/build
- ctest
+ cmake \
+ -S ${_pkgname} \
+ -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DBUILD_TESTING:BOOL=ON \
+ -DCMAKE_CXX_STANDARD:STRING=14 \
+ -DTPL_ENABLE_MPI:BOOL=ON \
+ -DCMAKE_C_COMPILER:STRING=/usr/bin/mpicc \
+ -DCMAKE_CXX_COMPILER:STRING=/usr/bin/mpic++ \
+ -DCMAKE_Fortran_COMPILER:STRING=/usr/bin/mpifort \
+ -DTrilinos_ENABLE_ALL_PACKAGES:BOOL=OFF \
+ -DTrilinos_ENABLE_FEI:BOOL=ON \
+ -DTrilinos_ENABLE_SEACAS:BOOL=OFF \
+ -DTrilinos_ENABLE_TESTS:BOOL=ON \
+ -DTrilinos_ENABLE_OpenMP:BOOL=ON \
+ -DTPL_ENABLE_MPI:BOOL=ON \
+ -DTrilinos_ENABLE_Zoltan=OFF \
+ -DTrilinos_ENABLE_PyTrilinos:BOOL=OFF \
+ -DTrilinos_ENABLE_Gtest:BOOL=ON \
+ -DTPL_ENABLE_Netcdf:BOOL=ON \
+ -DTPL_ENABLE_HDF5:BOOL=ON \
+ -DTPL_ENABLE_QT:BOOL=OFF \
+ -DTPL_ENABLE_GLM:BOOL=OFF \
+ -Wno-dev
+ cmake --build build --target all
}
package() {
- cd $srcdir/${_pkgname}/build
- make install DESTDIR=$pkgdir
+ DESTDIR="${pkgdir}" cmake --build build --target install
}