summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFyodor Doletov2021-11-28 22:30:32 +0300
committerFyodor Doletov2021-11-28 22:31:10 +0300
commitce7afbf42dd9962d3e8c75e031ecd39e357ff638 (patch)
treea72e96cabe3a5a997ec83b7ef100d5b150abf9fc
parent25df22f9aaa580d436fcb3ecdcc0bcb43f2e4a6f (diff)
downloadaur-ce7afbf42dd9962d3e8c75e031ecd39e357ff638.tar.gz
move repo to github
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
-rw-r--r--dependencies2
-rwxr-xr-xdown5
-rw-r--r--type1
-rwxr-xr-xup13
-rw-r--r--zram.conf2
7 files changed, 12 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a937ea8d8d7..f639b13a3404 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,14 @@
pkgbase = zram-s6
pkgdesc = Activate zram using skarnet's s6
pkgver = 1.0
- pkgrel = 3
- url = https://aur.archlinux.org/zram-s6
+ pkgrel = 4
+ url = https://github.com/Senderman/s6-services
arch = any
- license = GPL2
+ license = GPL3
depends = s6-base
provides = init-zram
conflicts = init-zram
- source = up
- source = down
- source = type
- source = zram.conf
- source = dependencies
- md5sums = 68efba65bf6726047ce6387e3a20d863
- md5sums = 99b762d9f10dba97223c614698c7a362
- md5sums = 85bceea1fb94d4166f24496dc40a35e6
- md5sums = 89743c52e3b1960cba82d822d742dfcd
- md5sums = 061880f66eb1b0e2fda2bb6788385640
+ source = git+https://github.com/Senderman/s6-services.git
+ md5sums = SKIP
pkgname = zram-s6
diff --git a/PKGBUILD b/PKGBUILD
index 872818125ecb..5c514d9b100c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,17 @@
pkgname=zram-s6
pkgdesc="Activate zram using skarnet's s6"
pkgver=1.0
-pkgrel=3
+pkgrel=4
arch=('any')
provides=('init-zram')
conflicts=('init-zram')
-url="https://aur.archlinux.org/$pkgname"
+url="https://github.com/Senderman/s6-services"
depends=('s6-base')
-license=('GPL2')
-source=('up' 'down' 'type' 'zram.conf' 'dependencies')
-md5sums=('68efba65bf6726047ce6387e3a20d863'
- '99b762d9f10dba97223c614698c7a362'
- '85bceea1fb94d4166f24496dc40a35e6'
- '89743c52e3b1960cba82d822d742dfcd'
- '061880f66eb1b0e2fda2bb6788385640')
-
+license=('GPL3')
+source=("git+${url}.git")
+md5sums=('SKIP')
package() {
- install -Dm0755 $srcdir/up $pkgdir/etc/s6/sv/zram/up
- install -Dm0755 $srcdir/down $pkgdir/etc/s6/sv/zram/down
- install -Dm0644 $srcdir/dependencies $pkgdir/etc/s6/sv/zram/dependencies
- install -Dm0644 $srcdir/type $pkgdir/etc/s6/sv/zram/type
- install -Dm0644 $srcdir/zram.conf $pkgdir/etc/s6/config/zram.conf
+ cd "$srcdir/s6-services"
+ sh install.sh "zram" "${pkgdir}"
}
diff --git a/dependencies b/dependencies
deleted file mode 100644
index 5e1b6b3a9b0f..000000000000
--- a/dependencies
+++ /dev/null
@@ -1,2 +0,0 @@
-mount-sysfs
-mount-devfs
diff --git a/down b/down
deleted file mode 100755
index a2915b47eb7c..000000000000
--- a/down
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/usr/bin/execlineb -P
-
-fdmove -c 2 1
-foreground { swapoff /dev/zram0 }
-rmmod zram
diff --git a/type b/type
deleted file mode 100644
index bdd22a1850ae..000000000000
--- a/type
+++ /dev/null
@@ -1 +0,0 @@
-oneshot
diff --git a/up b/up
deleted file mode 100755
index 28faf085c11b..000000000000
--- a/up
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/usr/bin/execlineb -P
-# Copyright 2021 Doletov Fyodor
-
-fdmove -c 2 1
-envfile /etc/s6/config/zram.conf
-importas comp_algorithm COMP_ALGORITHM
-importas zram_size ZRAM_SIZE
-
-foreground { modprobe zram }
-foreground { redirfd -w 1 /sys/block/zram0/comp_algorithm echo $comp_algorithm }
-foreground { redirfd -w 1 /sys/block/zram0/disksize echo $zram_size }
-foreground { mkswap --label zram0 /dev/zram0 }
-swapon --priority 100 /dev/zram0
diff --git a/zram.conf b/zram.conf
deleted file mode 100644
index 5005b6ff464d..000000000000
--- a/zram.conf
+++ /dev/null
@@ -1,2 +0,0 @@
-ZRAM_SIZE="4G"
-COMP_ALGORITHM="lzo-rle"