summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquantmint2020-05-06 15:07:49 +0200
committerquantmint2020-05-06 15:07:49 +0200
commitceba37e1c30f87ea2eddb392234526f08aadf7d0 (patch)
tree6041681f241fb39790b96361fbf59685e8747851
parent8363fa90595b253a801921cd0744ce4a1fa7868e (diff)
downloadaur-ceba37e1c30f87ea2eddb392234526f08aadf7d0.tar.gz
various changes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ea88f569ff9..0e6f9bbd98d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,8 +9,10 @@ pkgbase = godot-git
makedepends = git
makedepends = scons
makedepends = pulseaudio
- makedepends = clang
+ makedepends = gcc
makedepends = pkgconf
+ makedepends = xorg-xrandr
+ makedepends = yasm
depends = glu
depends = libxcursor
depends = libxinerama
@@ -19,10 +21,8 @@ pkgbase = godot-git
depends = mesa
provides = godot
conflicts = godot
- source = git://github.com/godotengine/godot.git#branch=master
source = godot.desktop
source = icon.png
- sha256sums = SKIP
sha256sums = 2ae039a3879b23e157f2125e0b326fa1ef66d56bfd596c790e8943d27652e93a
sha256sums = 99f9d17c4355b274ef0c08069cf6e756a98cd5c9d9d22d1b39f79538134277e1
diff --git a/PKGBUILD b/PKGBUILD
index 34ded13c8179..897131d7f5cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Cristian Porras <porrascristian@gmail.com>
+# Maintainer: QuantMint <qua/ntmint@/protonm/ail.com>
+# Contributor: Cristian Porras <porrascristian@gmail.com>
# Contributor: Matthew Bentley <matthew@mtbentley.us>
_pkgname=godot
@@ -9,7 +10,7 @@ pkgdesc="Godot Game Engine: An advanced, feature packed, multi-platform 2D and 3
url="http://www.godotengine.org"
license=('MIT')
arch=('i686' 'x86_64')
-makedepends=('git' 'scons' 'pulseaudio' 'clang' 'pkgconf')
+makedepends=('git' 'scons' 'pulseaudio' 'gcc' 'pkgconf' 'xorg-xrandr' 'yasm')
depends=('glu' 'libxcursor' 'libxinerama' 'alsa-lib' 'freetype2' 'mesa')
optdepends=()
conflicts=("godot")
@@ -22,16 +23,25 @@ else
fi
source=(
- "git://github.com/godotengine/${_pkgname}.git#branch=master"
godot.desktop
icon.png
)
sha256sums=(
- 'SKIP'
'2ae039a3879b23e157f2125e0b326fa1ef66d56bfd596c790e8943d27652e93a'
'99f9d17c4355b274ef0c08069cf6e756a98cd5c9d9d22d1b39f79538134277e1'
)
+prepare() {
+ if [ ! -d "${srcdir}/${_pkgname}" ]
+ then
+ cd ${srcdir}
+ git clone https://github.com/godotengine/godot.git --branch master --single-branch --depth 1
+ else
+ cd "${srcdir}/${_pkgname}"
+ git fetch --depth 1 origin master
+ git reset --hard origin/master
+ fi
+}
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -45,7 +55,7 @@ pkgver() {
build() {
cd "${srcdir}"/${_pkgname}
sed -n '/\/* Copyright/,/IN THE SOFTWARE./p' main/main.cpp | sed 's/\/\*//' | sed 's/\*\///' > LICENSE
- scons platform=linuxbsd target=release_debug use_llvm=yes -j$(nproc)
+ scons platform=linuxbsd target=release_debug -j$((`nproc`+1))
}
package() {
@@ -57,7 +67,7 @@ package() {
cd "${srcdir}"/${_pkgname}
- install -D -m755 bin/godot.linuxbsd.opt.tools.${_arch}.llvm "${pkgdir}"/usr/bin/godot
+ install -D -m755 bin/godot.linuxbsd.opt.tools.${_arch} "${pkgdir}"/usr/bin/godot
install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/godot-git/LICENSE
}