summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Beslik2016-09-17 16:45:49 +0300
committerRoman Beslik2016-09-17 16:45:49 +0300
commitced2895ee4d1b4f5ef2812e8803a85ab147605b4 (patch)
tree9801e023ec9a2970337903b834ba4478fe78bb57
downloadaur-ced2895ee4d1b4f5ef2812e8803a85ab147605b4.tar.gz
init
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD33
-rw-r--r--arch.patch11
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b59a48ad06ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = mozart1-bin
+ pkgdesc = An open source implementation of Oz 3.
+ pkgver = 1.4.0.20080704_16189
+ pkgrel = 1
+ url = https://mozart.github.io/mozart-v1/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = lib32-tk85
+ depends = emacs
+ depends = lib32-glibc
+ depends = lib32-zlib
+ depends = lib32-gmp4
+ depends = lib32-gcc-libs
+ depends = lib32-libx11
+ depends = lib32-libxss
+ depends = lib32-libxext
+ depends = lib32-libxcb
+ depends = lib32-libxau
+ depends = lib32-libxdmcp
+ conflicts = mozart2
+ source = bin.rpm::https://sourceforge.net/projects/mozart-oz/files/v1/1.4.0-2008-07-04-mandriva/mozart-1.4.0.20080704-16189.i586.rpm/download
+ source = arch.patch
+ sha512sums = 035b1260b5a4ecffb84440586ebc2cee381fba387f6d597baf525e1d7808da92d115108fbd7b94f6265ac50edb397d1bb147d2cc8bdc89753a03edf0eb7a3aee
+ sha512sums = c80faadc49f777396a83d0e6db2d68887b9c064f78b313f65357bc793320574f20c6293f66f3496ab501f13a02a89a68f14aced2dd0e905009199bc7af0f2474
+
+pkgname = mozart1-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..356e558e31c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Roman Beslik <me@beroal.in.ua>
+
+pkgname='mozart1-bin'
+pkgver='1.4.0.20080704_16189'
+pkgrel=1
+pkgdesc='An open source implementation of Oz 3.'
+arch=(i686 x86_64)
+url='https://mozart.github.io/mozart-v1/'
+license=(custom)
+depends=(lib32-tk85 emacs)
+conflicts=(mozart2)
+if [[ $CARCH == i686 ]]; then
+ depends+=(zlib gmp4 gcc-libs libx11 libxss libxext libxcb libxau libxdmcp)
+else
+ depends+=(lib32-{glibc,zlib,gmp4,gcc-libs,libx11,libxss,libxext,libxcb,libxau,libxdmcp})
+fi
+source=(bin.rpm::https://sourceforge.net/projects/mozart-oz/files/v1/1.4.0-2008-07-04-mandriva/mozart-1.4.0.20080704-16189.i586.rpm/download
+ arch.patch
+ )
+sha512sums=(035b1260b5a4ecffb84440586ebc2cee381fba387f6d597baf525e1d7808da92d115108fbd7b94f6265ac50edb397d1bb147d2cc8bdc89753a03edf0eb7a3aee
+ c80faadc49f777396a83d0e6db2d68887b9c064f78b313f65357bc793320574f20c6293f66f3496ab501f13a02a89a68f14aced2dd0e905009199bc7af0f2474
+ )
+prepare() {
+ cd "$srcdir"
+ patch -u -p1 < arch.patch
+ LICENSE_DIR="usr/share/licenses/$pkgname"
+ mkdir -p -m 755 "$LICENSE_DIR"
+ mv -t "$LICENSE_DIR" usr/lib/mozart/LICENSE*
+}
+package() {
+ cd "$srcdir"
+ cp -r -t "$pkgdir" usr etc
+}
diff --git a/arch.patch b/arch.patch
new file mode 100644
index 000000000000..5732dafef4ea
--- /dev/null
+++ b/arch.patch
@@ -0,0 +1,11 @@
+--- src/usr/lib/mozart/bin/ozplatform 2008-09-21 15:48:40.000000000 +0300
++++ src1/usr/lib/mozart/bin/ozplatform 2016-09-17 14:06:20.473679483 +0300
+@@ -36,7 +36,7 @@
+ ;;
+ RISC\ ULTRIX\ 4.*) OZARCH=ultrix-mips
+ ;;
+- i[4567]86\ Linux\ *) OZARCH=linux-i486
++ i[4567]86\ Linux\ *|x86_64\ Linux\ *) OZARCH=linux-i486
+ ;;
+ m68k\ Linux\ *) OZARCH=linux-m68k
+ ;;