summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2023-04-04 20:23:29 -0400
committerDarvin Delgado2023-04-04 20:23:29 -0400
commitceda3657e9ea56c726f38f9d098f18d6c5925e89 (patch)
tree0d9ff881b9780316c4e6b701ce996b9f129fd906
parent1498d95896d48c547c7dfd6f43f0eb5d62d4e0ba (diff)
downloadaur-ceda3657e9ea56c726f38f9d098f18d6c5925e89.tar.gz
remove use_system_vulkan
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 8 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c17f763b245..45cde8799628 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
pkgbase = lib32-mangohud-git
pkgdesc = A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more (32 bit library).
- pkgver = 0.6.8.r66.g8450291
+ pkgver = 0.6.8.r145.g020e848
pkgrel = 1
url = https://github.com/flightlessmango/MangoHud
arch = x86_64
license = MIT
- makedepends = gcc
makedepends = git
makedepends = glslang
makedepends = lib32-libx11
makedepends = libxnvctrl
makedepends = meson
makedepends = nlohmann-json
- makedepends = pkgconf
makedepends = python-mako
makedepends = vulkan-headers
depends = lib32-dbus
depends = lib32-vulkan-icd-loader
provides = lib32-mangohud
conflicts = lib32-mangohud
- source = lib32-mangohud::git+https://github.com/flightlessmango/MangoHud
+ source = lib32-mangohud-git::git+https://github.com/flightlessmango/MangoHud
sha512sums = SKIP
pkgname = lib32-mangohud-git
diff --git a/PKGBUILD b/PKGBUILD
index 6e76428c5801..0789588c77d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,30 @@
# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
-_pkgname=lib32-mangohud
pkgname=lib32-mangohud-git
-pkgver=0.6.8.r66.g8450291
+pkgver=0.6.8.r145.g020e848
pkgrel=1
pkgdesc="A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more (32 bit library)."
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-makedepends=('gcc' 'git' 'glslang' 'lib32-libx11' 'libxnvctrl' 'meson' 'nlohmann-json' 'pkgconf' 'python-mako' 'vulkan-headers')
+makedepends=('git' 'glslang' 'lib32-libx11' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako' 'vulkan-headers')
depends=('lib32-dbus' 'lib32-vulkan-icd-loader')
provides=('lib32-mangohud')
conflicts=('lib32-mangohud')
-source=("${_pkgname}::git+$url")
+source=("$pkgname::git+$url")
sha512sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd $pkgname
git describe --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
local meson_options=(
--wrap-mode=nofallback
- -Duse_system_vulkan=enabled
-Dinclude_doc=false
-Dtests=disabled
- "${pkgname%-git}"
+ $pkgname
)
export CC="gcc -m32"
@@ -42,10 +40,6 @@ build() {
package() {
meson install --destdir="$pkgdir" -C build --tags runtime
- if [ -f "$pkgdir/usr/lib32/libMangoHud.so" ]; then
- mv "$pkgdir/usr/lib32/libMangoHud.so" "$pkgdir/usr/lib32/mangohud/"
- fi
-
- install -Dm664 "${_pkgname}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm664 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
rm -rf "$pkgdir/usr/share/vulkan"
}