summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBao Trinh2022-12-06 14:05:54 -0600
committerBao Trinh2022-12-06 14:06:01 -0600
commitcee747cf7db61384bc2dc55a43ed1bb2416060f9 (patch)
tree86cfbcb9e642f94d269afc59893b12473139b9e6
parent892b6c556c78f7077b5be330efe6987f07a65f88 (diff)
downloadaur-cee747cf7db61384bc2dc55a43ed1bb2416060f9.tar.gz
v2.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
2 files changed, 28 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4ad4cea29f2..67ed12886e93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-autoflake
pkgdesc = Removes unused imports and unused variables
- pkgver = 1.4
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/myint/autoflake
arch = any
license = MIT
- makedepends = python
+ makedepends = python-setuptools
+ depends = python
depends = python-pyflakes
- source = https://github.com/myint/autoflake/archive/v1.4.tar.gz
- sha256sums = b3c573b0ab507b22359e80bdfd4c3fcf64b1b1d3352a6209a9fe73116c0ed36e
+ depends = python-tomli
+ source = https://github.com/myint/autoflake/archive/v2.0.0.tar.gz
+ sha256sums = b8b945a9adf5c8231f49fde2c1422e3618af4826825f6f8033e29434c71bf1bc
pkgname = python-autoflake
diff --git a/PKGBUILD b/PKGBUILD
index 6665ffd6c700..c539339e8dc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,39 @@
# Python package author: Steven Myint <UNKNOWN>
_name=autoflake
pkgname=python-autoflake
-pkgver=1.4
+pkgver=2.0.0
pkgrel=1
pkgdesc='Removes unused imports and unused variables'
arch=(any)
url="https://github.com/myint/$_name"
license=("MIT")
-depends=('python-pyflakes')
-makedepends=('python')
+depends=(
+ 'python'
+ 'python-pyflakes'
+ # required for python<3.11
+ 'python-tomli'
+)
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-pytest'
+)
source=("https://github.com/myint/$_name/archive/v${pkgver}.tar.gz")
-sha256sums=('b3c573b0ab507b22359e80bdfd4c3fcf64b1b1d3352a6209a9fe73116c0ed36e')
+sha256sums=('b8b945a9adf5c8231f49fde2c1422e3618af4826825f6f8033e29434c71bf1bc')
build() {
+ pwd
+ ls -lah
cd "$srcdir/$_name-$pkgver"
- python setup.py build
+ python -m build -nw
+}
+
+check() {
+ cd "$srcdir/$_name-$pkgver"
+ pytest
}
package() {
cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer -d "$pkgdir" dist/*.whl
}