summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commitcef68c4b8dac5711ba50dad47e3bcc40e4fa4b29 (patch)
treeb78ffc359bd672572d62f04bc2ed93e31c898065
downloadaur-cef68c4b8dac5711ba50dad47e3bcc40e4fa4b29.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--vimdoc.install24
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2960da7d565e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-bash-support
+ pkgdesc = BASH-IDE - Write and run BASH-scripts using menus and hotkeys.
+ pkgver = 4.2.1
+ pkgrel = 1
+ url = http://vim.sourceforge.net/scripts/script.php?script_id=365
+ install = vimdoc.install
+ arch = any
+ license = custom:vim
+ depends = vim-vim-support
+ optdepends = bashdb: bash debugger
+ noextract = vim-bash-support-4.2.1.zip
+ source = vim-bash-support-4.2.1.zip::http://www.vim.org/scripts/download_script.php?src_id=21804
+ sha256sums = 67aab863783dd72ba9a963b3e2c0e1754cd93795cf661fdeb5e699b1b3841742
+
+pkgname = vim-bash-support
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc09173d766a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: 3ED <krzysztof1987 _at_ gmail _dot_ com>
+
+pkgname=vim-bash-support
+pkgver=4.2.1
+_srcid=21804
+pkgrel=1
+pkgdesc='BASH-IDE - Write and run BASH-scripts using menus and hotkeys. '
+arch=('any')
+url='http://vim.sourceforge.net/scripts/script.php?script_id=365'
+license=('custom:vim')
+depends=('vim-vim-support')
+optdepends=('bashdb: bash debugger')
+install='vimdoc.install'
+source=("${pkgname}-${pkgver}.zip::http://www.vim.org/scripts/download_script.php?src_id=$_srcid")
+noextract=("${pkgname}-${pkgver}.zip")
+sha256sums=('67aab863783dd72ba9a963b3e2c0e1754cd93795cf661fdeb5e699b1b3841742')
+
+package() {
+ _DESTDIR="$pkgdir"/usr/share/vim/vimfiles
+
+ install -dm755 "${_DESTDIR}"
+ bsdtar -xf ${pkgname}-${pkgver}.zip -C "${_DESTDIR}" \
+ --exclude "autoload/mmtemplates/core.vim" \
+ --exclude "doc/templatesupport.txt" \
+ --exclude "syntax/template.vim"
+
+ # Fix perms
+ chmod -R a=r,a+X,u+w "${_DESTDIR}"
+}
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..488184f0c2cb
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,24 @@
+vimdocinstall() {
+ echo -n "updating Vim help tags... "
+ usr/bin/vim --noplugin -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+
+post_install() {
+ vimdocinstall
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ vimdocinstall
+}
+
+op=$1
+shift
+
+$op $*