summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-03-08 20:27:36 +0000
committerDaniel Bermond2019-03-08 20:27:36 +0000
commitcf1a01cee10617ef14c67000911e0b3259d31812 (patch)
tree3e78ddc34dcd0a89d51933f74732c706932cbf1f
parent7a8bcdff215ad7cfd8b492b40077edf9fc73f904 (diff)
downloadaur-cf1a01cee10617ef14c67000911e0b3259d31812.tar.gz
Updated to version 19.07.1542
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE2
-rw-r--r--PKGBUILD18
3 files changed, 16 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2be52d20f4f..13d81a88618b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,25 @@
pkgbase = intel-graphics-compiler-bin
pkgdesc = Intel Graphics Compiler for OpenCL
- pkgver = 18.48.1124
+ pkgver = 19.07.1542
pkgrel = 1
url = https://github.com/intel/intel-graphics-compiler/
arch = x86_64
license = MIT
depends = gcc-libs
depends = zlib
- depends = ncurses5-compat-libs
provides = intel-graphics-compiler
conflicts = intel-graphics-compiler
conflicts = compute-runtime
- noextract = intel-igc-core_18.48.1124_amd64.deb
- noextract = intel-igc-opencl_18.48.1124_amd64.deb
+ noextract = intel-igc-core_19.07.1542_amd64.deb
+ noextract = intel-igc-opencl_19.07.1542_amd64.deb
options = !strip
options = !emptydirs
- source = https://github.com/intel/compute-runtime/releases/download/18.49.11968/intel-igc-core_18.48.1124_amd64.deb
- source = https://github.com/intel/compute-runtime/releases/download/18.49.11968/intel-igc-opencl_18.48.1124_amd64.deb
+ source = https://github.com/intel/compute-runtime/releases/download/19.09.12487/intel-igc-core_19.07.1542_amd64.deb
+ source = https://github.com/intel/compute-runtime/releases/download/19.09.12487/intel-igc-opencl_19.07.1542_amd64.deb
source = LICENSE
- sha256sums = f0dd87998a290a713295e9b3498fc49545e7e4c15710ed1d11055e160c1bff17
- sha256sums = 7aaf3560d86a8c6be7e7dbc696a16cd030ccc8aea5fda07bcb86d2dbe3590de2
- sha256sums = 0a17bb0830659515e66a960a6fd553d9ef939bc8097066e1c8f4954d562c252c
+ sha256sums = 9e5c130df7fe95b860f4c761620bf6fd5f814930df3f06c5e698aa846cadece5
+ sha256sums = 964e714899347564af99fe2a3619e7e630e52b74a88d96f183a27a934bbe79ca
+ sha256sums = 4099c7bc8a69e9e9c82f898e75870435cc0ca989a816a8ba6e38faabc88f0c36
pkgname = intel-graphics-compiler-bin
diff --git a/LICENSE b/LICENSE
index 52e428865a39..f270353f33fe 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,4 +1,4 @@
-Copyright (c) 2018, Intel Corporation
+Copyright (c) 2019, Intel Corporation
Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the "Software"),
diff --git a/PKGBUILD b/PKGBUILD
index 5c3d1b00c9e1..f90c73d7f258 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,14 @@
# repository. $pkgver is currently inherited from there.
pkgname=intel-graphics-compiler-bin
-pkgver=18.48.1124
-_icrver=18.49.11968 # intel-compute-runtime version
+pkgver=19.07.1542
+_icrver=19.09.12487 # intel-compute-runtime version
pkgrel=1
pkgdesc='Intel Graphics Compiler for OpenCL'
arch=('x86_64')
url='https://github.com/intel/intel-graphics-compiler/'
license=('MIT')
-depends=(
- # official repositories:
- 'gcc-libs' 'zlib'
- # AUR:
- 'ncurses5-compat-libs'
-)
+depends=('gcc-libs' 'zlib')
provides=('intel-graphics-compiler')
conflicts=('intel-graphics-compiler' 'compute-runtime')
options=('!strip' '!emptydirs')
@@ -26,9 +21,9 @@ source=("https://github.com/intel/compute-runtime/releases/download/${_icrver}/i
'LICENSE')
noextract=("intel-igc-core_${pkgver}_amd64.deb"
"intel-igc-opencl_${pkgver}_amd64.deb")
-sha256sums=('f0dd87998a290a713295e9b3498fc49545e7e4c15710ed1d11055e160c1bff17'
- '7aaf3560d86a8c6be7e7dbc696a16cd030ccc8aea5fda07bcb86d2dbe3590de2'
- '0a17bb0830659515e66a960a6fd553d9ef939bc8097066e1c8f4954d562c252c')
+sha256sums=('9e5c130df7fe95b860f4c761620bf6fd5f814930df3f06c5e698aa846cadece5'
+ '964e714899347564af99fe2a3619e7e630e52b74a88d96f183a27a934bbe79ca'
+ '4099c7bc8a69e9e9c82f898e75870435cc0ca989a816a8ba6e38faabc88f0c36')
prepare() {
mkdir -p igc-{core,opencl}-"$pkgver"
@@ -41,6 +36,7 @@ package() {
tar -Jxf "igc-core-${pkgver}/data.tar.xz" -C "$pkgdir"
tar -Jxf "igc-opencl-${pkgver}/data.tar.xz" -C "$pkgdir"
+ mkdir -p "${pkgdir}/usr/lib"
mv "$pkgdir"/usr/local/lib/* "${pkgdir}/usr/lib"
# fix wrong ownerships