summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-10-11 10:30:46 -0600
committerMark Wagie2023-10-11 10:30:46 -0600
commitcf1f44762828cb235763a398cfab9843271e40ce (patch)
treefc00072930b879c1318e0d435d1b7de450ff816b
parent95d2682ea3898dc04524a6e78bd09546ad246e53 (diff)
downloadaur-cf1f44762828cb235763a398cfab9843271e40ce.tar.gz
4.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96a7c37f849b..e9cec361ba99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = commit
pkgdesc = Commit message editor.
- pkgver = 4.0
- pkgrel = 2
- url = https://apps.gnome.org/app/re.sonny.Commit
+ pkgver = 4.1
+ pkgrel = 1
+ url = https://apps.gnome.org/Commit
arch = any
license = GPL3
checkdepends = appstream-glib
@@ -10,11 +10,12 @@ pkgbase = commit
makedepends = git
makedepends = meson
depends = libadwaita
+ depends = libspelling
depends = gjs
depends = gtksourceview5
optdepends = git: git support
optdepends = mercurial: mercurial support
- source = git+https://github.com/sonnyp/Commit.git#commit=a2dfeddd38ed96bbd0f4ce29fb6a1bc5b215ee44
+ source = git+https://github.com/sonnyp/Commit.git#commit=c7db2f4140053755689c35862964f9568c5e284b
source = git+https://github.com/sonnyp/troll.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index aa5d110a5211..c4ab5bf03127 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=commit
-pkgver=4.0
-pkgrel=2
+pkgver=4.1
+pkgrel=1
pkgdesc="Commit message editor."
arch=('any')
-url="https://apps.gnome.org/app/re.sonny.Commit"
+url="https://apps.gnome.org/Commit"
license=('GPL3')
-depends=('libadwaita' 'gjs' 'gtksourceview5')
+depends=('libadwaita' 'libspelling' 'gjs' 'gtksourceview5')
makedepends=('blueprint-compiler' 'git' 'meson')
checkdepends=('appstream-glib')
optdepends=('git: git support'
- 'mercurial: mercurial support'
-# 'gspell: spell checking support' # Spell checking has been temporarily removed
- )
-_commit=a2dfeddd38ed96bbd0f4ce29fb6a1bc5b215ee44 # tags/v4.0^0
+ 'mercurial: mercurial support')
+_commit=c7db2f4140053755689c35862964f9568c5e284b # tags/v4.1^0
source=("git+https://github.com/sonnyp/Commit.git#commit=$_commit"
'git+https://github.com/sonnyp/troll.git')
sha256sums=('SKIP'
'SKIP')
+pkgver() {
+ cd Commit
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
prepare() {
cd Commit
git submodule init