summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2020-06-04 16:10:28 +0300
committerIvan Shapovalov2020-06-04 16:10:28 +0300
commitcf57c9bfff8018fab2b7dc07fd9aa3405620e47d (patch)
treecfbaeb29bd3dc63a7000c8f94089c0a75d2d4870
parent9d1f545fcdd19c4b9ebc6f0eac31da08b1b8ab7f (diff)
downloadaur-cf57c9bfff8018fab2b7dc07fd9aa3405620e47d.tar.gz
Bump to 0.14.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54db07dd2b44..dc7d5d7db2b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python-authlib
pkgdesc = The ultimate Python library in building OAuth and OpenID Connect servers.
- pkgver = 0.13
+ pkgver = 0.14.3
pkgrel = 1
url = https://authlib.org/
arch = any
license = BSD
makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/source/A/Authlib/Authlib-0.13.tar.gz
- sha256sums = 401a4a184379a6551b79af30243ce1ad56da0a8da5b4925e0be260f07ee40009
+ source = https://files.pythonhosted.org/packages/source/A/Authlib/Authlib-0.14.3.tar.gz
+ sha256sums = cc52908e9e996f3de2ac2f61bf1ee6c6f1c5ce8e67c89ff2ca473008fffc92f6
pkgname = python-authlib
- depends = python
diff --git a/PKGBUILD b/PKGBUILD
index f28938670d8f..c37b5def4418 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
pkgbase='python-authlib'
pkgname=('python-authlib')
-_module='Authlib'
-pkgver='0.13'
+pkgver=0.14.3
pkgrel=1
pkgdesc="The ultimate Python library in building OAuth and OpenID Connect servers."
url="https://authlib.org/"
@@ -9,16 +8,15 @@ depends=('python')
makedepends=('python-setuptools')
license=('BSD')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('401a4a184379a6551b79af30243ce1ad56da0a8da5b4925e0be260f07ee40009')
+source=("https://files.pythonhosted.org/packages/source/A/Authlib/Authlib-$pkgver.tar.gz")
+sha256sums=('cc52908e9e996f3de2ac2f61bf1ee6c6f1c5ce8e67c89ff2ca473008fffc92f6')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "Authlib-$pkgver"
python setup.py build
}
package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "Authlib-$pkgver"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}