summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNazar Vinnichuk2020-06-02 17:20:50 +0300
committerNazar Vinnichuk2020-06-02 17:20:50 +0300
commitcf975a9afd4c1bfd8113f1be0be179294a8f624e (patch)
treed7b8113a49112f35973bd545603743c17aad40f5
parent38468857769eec2c177b7c008332d972456c35f3 (diff)
downloadaur-cf975a9afd4c1bfd8113f1be0be179294a8f624e.tar.gz
Do not spit hyphens in pkgver.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b0dd9699b0c..48a89ad3e6e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pacwall-git
pkgdesc = Dependency graph of installed packages on your wallpaper.
- pkgver = 1.1
+ pkgver = 1.1.r1.gd36b113
pkgrel = 1
url = http://github.com/Kharacternyk/pacwall
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 299789fa4ab3..cd2502d8e901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nazar Vinnichuk <nazar.vinnichuk at tutanota dot com>
pkgname=pacwall-git
_pkgname=${pkgname%-git}
-pkgver=1.1
+pkgver=1.1.r1.gd36b113
pkgrel=1
pkgdesc="Dependency graph of installed packages on your wallpaper."
url="http://github.com/Kharacternyk/${_pkgname}"
@@ -19,7 +19,7 @@ sha256sums=(SKIP)
pkgver() {
cd "${srcdir}/${_pkgname}"
- local _version="$(git describe --tags --match 'v*')"
+ local _version="$(git describe --tags --match 'v*' | sed 's/-/.r/' | sed 's/-/./')"
printf "${_version#v}"
}