summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2020-01-11 13:27:08 +0100
committerGordian Edenhofer2020-01-11 13:28:43 +0100
commitcf9bdfeb68e602e603b0ca58eb2b9eab94002395 (patch)
tree62cffdffa5545aa009080facca66984700c40dd8
parent8d7bc62ab17496723d015a036a4bf192432eeccb (diff)
downloadaur-cf9bdfeb68e602e603b0ca58eb2b9eab94002395.tar.gz
upgpkg: certbot-git 1.0.0.r23.gceea41c1e-1
Drop the python2 versions as the language has reached its EOL. upgpkg: certbot-plugins-git 1.0.0.r23.gceea41c1e-1 upgpkg: letshelp-certbot-git 1.0.0.r23.gceea41c1e-1 upgpkg: python-acme-git 1.0.0.r23.gceea41c1e-1
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD46
2 files changed, 14 insertions, 80 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 303f43d65147..83eb2f502467 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,37 +1,11 @@
pkgbase = python-acme-git
pkgdesc = ACME protocol implementation for Python
- pkgver = 0.40.0.r4.g9b848b1d6
+ pkgver = 1.0.0.r23.gceea41c1e
pkgrel = 1
url = https://github.com/certbot/certbot
arch = any
license = Apache
makedepends = git
- makedepends = python-setuptools
- makedepends = python2-setuptools
- makedepends = python-pyasn1
- makedepends = python2-pyasn1
- makedepends = python-cryptography
- makedepends = python2-cryptography
- makedepends = python-pyopenssl
- makedepends = python2-pyopenssl
- makedepends = python-ndg-httpsclient
- makedepends = python2-ndg-httpsclient
- makedepends = python-pyrfc3339
- makedepends = python2-pyrfc3339
- makedepends = python-pytz
- makedepends = python2-pytz
- makedepends = python-requests
- makedepends = python2-requests
- makedepends = python-six
- makedepends = python2-six
- makedepends = python-werkzeug
- makedepends = python2-werkzeug
- makedepends = python-mock
- makedepends = python2-mock
- source = certbot::git+https://github.com/certbot/certbot
- sha512sums = SKIP
-
-pkgname = python-acme-git
depends = python-setuptools
depends = python-pyasn1
depends = python-cryptography
@@ -44,21 +18,9 @@ pkgname = python-acme-git
depends = python-werkzeug
depends = python-mock
optdepends = python-dnspython: local validation of dns-01 challenges
- provides = python-acme=0.40.0.r4.g9b848b1d6
+ provides = python-acme=1.0.0.r23.gceea41c1e
conflicts = python-acme
+ source = certbot::git+https://github.com/certbot/certbot
+ sha512sums = SKIP
-pkgname = python2-acme-git
- depends = python2-setuptools
- depends = python2-pyasn1
- depends = python2-cryptography
- depends = python2-pyopenssl
- depends = python2-ndg-httpsclient
- depends = python2-pyrfc3339
- depends = python2-pytz
- depends = python2-requests
- depends = python2-six
- depends = python2-werkzeug
- depends = python2-mock
- optdepends = python2-dnspython: local validation of dns-01 challenges
- provides = python2-acme=0.40.0.r4.g9b848b1d6
- conflicts = python2-acme
+pkgname = python-acme-git
diff --git a/PKGBUILD b/PKGBUILD
index eb2e5b230ace..17db806eac08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Gordian Edenhofer <gordian.edenhofer@gmail.com>
-pkgbase=python-acme-git
-pkgname=("python-acme-git" "python2-acme-git")
+pkgname=python-acme-git
_reponame="certbot"
-pkgver=0.40.0.r4.g9b848b1d6
+pkgver=1.0.0.r23.gceea41c1e
pkgrel=1
pkgdesc="ACME protocol implementation for Python"
arch=('any')
license=('Apache')
url="https://github.com/certbot/${_reponame}"
-makedepends=('git' 'python-setuptools' 'python2-setuptools' 'python-pyasn1' 'python2-pyasn1'
- 'python-cryptography' 'python2-cryptography' 'python-pyopenssl' 'python2-pyopenssl'
- 'python-ndg-httpsclient' 'python2-ndg-httpsclient' 'python-pyrfc3339'
- 'python2-pyrfc3339' 'python-pytz' 'python2-pytz' 'python-requests'
- 'python2-requests' 'python-six' 'python2-six' 'python-werkzeug' 'python2-werkzeug'
- 'python-mock' 'python2-mock')
+depends=('python-setuptools' 'python-pyasn1' 'python-cryptography' 'python-pyopenssl'
+ 'python-ndg-httpsclient' 'python-pyrfc3339' 'python-pytz' 'python-requests'
+ 'python-six' 'python-werkzeug' 'python-mock')
+optdepends=("python-dnspython: local validation of dns-01 challenges")
+makedepends=('git')
+provides=("python-acme=${pkgver}")
+conflicts=("python-acme")
source=("${_reponame}"::"git+https://github.com/certbot/${_reponame}")
sha512sums=('SKIP')
@@ -26,42 +26,14 @@ pkgver() {
)
}
-prepare() {
- cp -a "${srcdir}/${_reponame}/acme"{,-py2}
-}
-
build() {
cd "${srcdir}/${_reponame}/acme"
python setup.py clean
rm -rf build dist
python setup.py build
-
- cd "${srcdir}/${_reponame}/acme-py2"
- python2 setup.py clean
- rm -rf build dist
- python2 setup.py build
}
package_python-acme-git() {
- depends=('python-setuptools' 'python-pyasn1' 'python-cryptography' 'python-pyopenssl'
- 'python-ndg-httpsclient' 'python-pyrfc3339' 'python-pytz' 'python-requests'
- 'python-six' 'python-werkzeug' 'python-mock')
- optdepends=("python-dnspython: local validation of dns-01 challenges")
- provides=("python-acme=${pkgver}")
- conflicts=("python-acme")
-
cd "${srcdir}/${_reponame}/acme"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
-
-package_python2-acme-git() {
- depends=('python2-setuptools' 'python2-pyasn1' 'python2-cryptography' 'python2-pyopenssl'
- 'python2-ndg-httpsclient' 'python2-pyrfc3339' 'python2-pytz' 'python2-requests'
- 'python2-six' 'python2-werkzeug' 'python2-mock')
- optdepends=("python2-dnspython: local validation of dns-01 challenges")
- provides=("python2-acme=${pkgver}")
- conflicts=("python2-acme")
-
- cd "${srcdir}/${_reponame}/acme-py2"
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
-}